Ask Your Question

Where did SimpleBlobDetection go?

asked 2019-07-07 17:25:25 -0600

eric_engineer gravatar image

I was using SimpleBlobDetection in 3.x in Java. Then I updated to 4.x and now I can't find it anywhere. FeatureDetector seems to have been replaced by FastFeatureDetector, but I can't find SimpleBlob anywhere.

Thank you

edit retag flag offensive close merge delete


where's the problem, exactly ?

berak gravatar imageberak ( 2019-07-07 23:56:45 -0600 )edit

If I do an import org.opencv.features2d.SimpleBlobDetector;. I get a cannot resolve symbol SimpleBlobDetector. If I were to do a import org.opencv.features2d.MSER; that would work. I also tried importing org.opencv.features2d.Feature2D; org.opencv.features2d.Features2d; org.opencv.features2d.*; Then SimpleBlobDetector detector = new SimpleBlobDetector(); but I still get cannot resolve symbol. I can do it like that with MSER though.

eric_engineer gravatar imageeric_engineer ( 2019-07-08 06:16:32 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2019-07-08 07:32:41 -0600

berak gravatar image

updated 2019-07-08 07:33:19 -0600

please update to latest master or 4.1. 4.0.0 indeed does not have it.

also note, that it should be:

SimpleBlobDetector detector = SimpleBlobDetector.create();

(there is no public constructor , you can't use new)

edit flag offensive delete link more


So was already using 4.1.0 and I can't get it to work there. I'm trying to build master from source buy having trouble with some mingw errors.

eric_engineer gravatar imageeric_engineer ( 2019-07-09 15:22:46 -0600 )edit

Question Tools

1 follower


Asked: 2019-07-07 17:25:25 -0600

Seen: 240 times

Last updated: Jul 07 '19