Ask Your Question
0

about the error in 'debayer.cu'

asked 2019-01-12 14:58:32 -0500

kundo gravatar image

Hi, I'm Kundo.

I'm trying to build OpenCV using the source I downloaded hear 'https://github.com/opencv/opencv' and 'https://github.com/opencv/opencv_contrib' here with Cmake.

I'm using Windows 10 64bit, Visual Studio 2015 community, and Cuda ver 10.0.

When I try to build OpenCV, the error occurs in 'debayer.cu' which causes the error in 'color_detail.hpp' and 'opencv_cudaimgproc' too.

the error says

  1. it needs ')' in line 394
  2. 'texture' is not a template in line 394
  3. there is no global variable 'max', and 'min' in line 69, 73, 77, 235, 239, 243, 70, 74, 78, 236, 240, 244

(sorry I just translated the error message cause I'm not using English ver..)

I have no idea how should I solve this.

I didn't change anything in 'debayer.cu'.

thank you.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2019-01-13 12:12:59 -0500

updated 2019-01-13 12:14:08 -0500

Hi, did you check out the 4.0.0 tag to build a stable release or are you building from the latest commit?

Did you follow steps similar to those in the Build OpenCV 4.0.0 with CUDA 10.0 and Intel MKL +TBB in Windows guide? If not what were the different options you used apart from an earlier version of Visual Studio?

edit flag offensive delete link more

Comments

Hi, Thank you for your answer. Because my VS is 2015 version, I changed CUDA 10 to version 9.1 and used OpenCV 3.4 as the link you wrote recommended. I followed the instruction and the only difference is I used TBB 2019 version.

but the same error occurs. https://github.com/opencv/opencv_cont...

in the link,

The same problems occur in the same lines..

Thank you.

kundo gravatar imagekundo ( 2019-01-14 00:58:58 -0500 )edit

And I included With_Openni2 through Cmake, and unchecked Build_opencv_world

kundo gravatar imagekundo ( 2019-01-14 01:19:35 -0500 )edit

Sorry I have no experience with installing openni. Have you first confirmed that you can build opencv_world without openni support? To do build this more quickly make sure you pass the -DCUDA_ARCH_BIN=x.x -DCUDA_ARCH_PTX=x.x flags suitable for your architecture only to CMake.

cudawarped gravatar imagecudawarped ( 2019-01-14 03:20:51 -0500 )edit
0

answered 2019-03-13 12:05:06 -0500

bujan gravatar image

Patch this file: modules/core/include/opencv2/core/cuda/detail/color_detail.hpp

according to this update "Windows Build Issue Fix" link text

You can simply download it and overwrite the old one in the corresponding path

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-12 14:58:32 -0500

Seen: 68 times

Last updated: Jan 13