OPENCV 3.3 CMAKE error in windows 10

asked 2017-10-13 01:11:22 -0500

pranan gravatar image

updated 2017-10-13 01:24:43 -0500

berak gravatar image

Trying to compile opencv 3.3 with IPP in windows 10 with mingw . Earlier With IPP was giving error. That is solved with the patch given in this forum. But now I am getting the following error in CMAKE. Any help appreciated. thanks in advance.

Configuring done
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_core" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_flann" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_imgproc" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_ml" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_objdetect" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_phase_unwrapping" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_photo" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_plot" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_reg" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_surface_matching" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_video" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_xphoto" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_bgsegm" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_dnn" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_face" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_fuzzy" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_img_hash" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_imgcodecs" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_shape" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_videoio" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_xobjdetect" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_highgui" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_superres" which requires target "RunTmChkAlt" that is not in the export set.
CMake Error: install(EXPORT "OpenCVModules" ...) includes target "opencv_bioinspired" which requires target "RunTmChkAlt" that is not in ...
(more)
edit retag flag offensive close merge delete

Comments

just to be sure, did you mean this patch ? (same error msgs)

berak gravatar imageberak ( 2017-10-13 01:28:59 -0500 )edit

Yes the same patch...

At the end of that discussion I see similar errors posted for Ubuntu with mingw-w64 5 + IPPICV combination.

My combination is windows 10, mingw, IPP and opencv 3.3

pranan gravatar imagepranan ( 2017-10-13 05:10:17 -0500 )edit