Ask Your Question

Windows 7 installation fail: 'Can not open file OpenCV...exe as archive'

asked 2013-07-19 22:16:54 -0500

JDS gravatar image

Having a really tough time installing OpenCV on my Windows 7 64-bit machine. Yes I tried running as administrator; I also tried 7zip and WinRAR to extract. No dice.

I have downloaded OpenCV-2.4.4.exe, OpenCV-2.4.5.exe, OpenCV-, and now I'm trying OpenCV-2.3.0.exe =(


edit retag flag offensive close merge delete


I have windows 7 x64 bits, downloading the prebuilt binaries and doubleclicking still works perfect for me. To me this seems as your system is blocking the execution of it. Can you check if any virus detector/malware detector/firewall is blocking the installation?

StevenPuttemans gravatar imageStevenPuttemans ( 2013-07-20 03:08:36 -0500 )edit

@StevenPuttemans I just downoaded the 2.4.9.exe , i click and it execute in dos for a long time , now am checking it in my drives , its not there , so how can check its confirmation of installation . Thanks

FLY gravatar imageFLY ( 2015-03-03 18:14:50 -0500 )edit

@FLY I wonder why it opens up in DOS for you, for me it opens up an extraction program which allows me to select the installation folder. Did you download it from the official repos?

StevenPuttemans gravatar imageStevenPuttemans ( 2015-03-04 03:21:00 -0500 )edit

@StevenPuttemans I downloaded it from here , though opencv4android install exactaly the way your guiding.

FLY gravatar imageFLY ( 2015-03-04 10:02:49 -0500 )edit

If I look at the official download page than there isnt a 2.4.11 package. Please select one from there only!

StevenPuttemans gravatar imageStevenPuttemans ( 2015-03-04 10:15:53 -0500 )edit

Thanks @steven , Actually i use the official link as well , i Click on beta version 3.0 (OpenCV for Windows) then next page opens then next page displays Looking for the latest version? Download opencv-2.4.11.exe (367.7 MB) and i click on it.

FLY gravatar imageFLY ( 2015-03-04 13:06:44 -0500 )edit

Weird, if I click that link it suggests to download Looking for the latest version? Download (91.7 MB) Could you clear out your browser history or manually try OpenCV2.4.10?

StevenPuttemans gravatar imageStevenPuttemans ( 2015-03-05 02:07:45 -0500 )edit

I will open new thread with snapshots

FLY gravatar imageFLY ( 2015-03-06 06:02:09 -0500 )edit

@FLY did you even try the suggestions?

StevenPuttemans gravatar imageStevenPuttemans ( 2015-03-06 06:03:28 -0500 )edit
FLY gravatar imageFLY ( 2015-03-06 10:31:23 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2013-07-22 00:51:23 -0500

Seems like you already accepted an answer for this question on stackoverflow. What was wrong with it?

Maybe you wanna check your archiving program and give 7-Zip a try.

edit flag offensive delete link more

Question Tools


Asked: 2013-07-19 22:16:54 -0500

Seen: 5,392 times

Last updated: Jul 22 '13