Ask Your Question
0

low time performance on Ubuntu 14

asked 2017-02-15 10:56:46 -0500

salzis gravatar image

Hello everyone,

I have a very unusual issue with OpenCV 3.2 on my Ubuntu 14 machine. Time performance for image pre-processing functions such as CvtColor and remap is a way lower as compared to the Windows version. I'm building my application using cmake (in Release mode), OpenCV is compiled in Release as well... Any ideas what can be wrong?!

Many thanks in advance!

Best, Alexey

edit retag flag offensive close merge delete

Comments

Is it same graphic card?

LBerger gravatar imageLBerger ( 2017-02-15 11:17:53 -0500 )edit

no, on the Linux machine: GeForce GTX 660 Ti on the Windows: Quadro 1000M

salzis gravatar imagesalzis ( 2017-02-15 11:25:32 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-02-15 14:42:54 -0500

LBerger gravatar image

Quadro 1000M seems better than GTX 660. opencv can take advantage of the hardware acceleration Opencl or cuda.

edit flag offensive delete link more

Comments

This is one possibility, but my best guess, your linux installation probably doesn't have the same optimization flags as the windows installation. Compare your CMAKE outputs step by step.

StevenPuttemans gravatar imageStevenPuttemans ( 2017-02-16 08:31:15 -0500 )edit

I think my answer is wrong :

  1. LINUX GTx 660
  2. Windows: Quadro 1000M
LBerger gravatar imageLBerger ( 2017-02-16 08:39:48 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-15 10:56:46 -0500

Seen: 62 times

Last updated: Feb 15 '17