Ask Your Question
0

OpenCL example failed on Mac OS X 10.8.3

asked 2013-04-22 17:56:03 -0500

wonwoolee gravatar image

I installed OpenCV 2.4.5 with OpenCL support from Macports, and Installation was successful.

When I tried to run the sample 'square', it failed with the following error:

OpenCV Error: Assertion failed (localThreads[0] * localThreads[1] * localThreads[2] <= kernelWorkGroupSize) in openCLVerifyKernel

I tried it on both CPU and GPU of my macbook pro retina 15 inch, but never succeed to run it. It seems that most of cv::ocl functions cause errors. Anybody could run the example, even on MS Windows ?

edit retag flag offensive close merge delete

Comments

Did you ever find out what caused this? I am having the exact same issue (with a different demo, but still).

Hansg91 gravatar imageHansg91 ( 2013-06-24 16:52:10 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-04-23 07:34:11 -0500

I was faced with same error. So, I checked official document. There is the following explanation in this document.

Many kernels use 256 as its workgroup size if possible, so the max work group size of the device must larger than 256. All GPU devices we are aware of indeed support 256 workitems in a workgroup, however non GPU devices may not. This will be improved in the future.

So, your hardware(CPU or GPU) may not meet this requirements. I recommend that you check your hardware spec.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-04-22 17:56:03 -0500

Seen: 954 times

Last updated: Apr 23 '13