Ask Your Question

compiling openCV 2.4.5 under VS 2012 x64

asked 2013-04-22 07:17:21 -0600

Ben gravatar image

I just downloaded OpenCV 2.4.5 for Windows and tried to compile it using CMake (GUI), but I get the following error when configuring cmake:

The CXX compiler identification is unknown
The C compiler identification is unknown
CMake Error at CMakeLists.txt:69 (message):
  CMake fails to deterimine the bitness of target platform.

    Please check your CMake and compiler installation. If you are crosscompiling then ensure that your CMake toolchain file correctly sets the compiler details.

Configuring incomplete, errors occurred!

I chose Visual Studio 11 Win64 compiler, but the same happens to other compilers. And I had the same error with 2.4.4. What can I do?

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted

answered 2013-06-28 14:26:01 -0600

sumit_K gravatar image

Ben, I have a solution to this problem. Can you tell me how can I post it here? This space is screwing up my comments :(

edit flag offensive delete link more


Actually this topic show the exact solution. I already pointed @Ben to it!

StevenPuttemans gravatar imageStevenPuttemans ( 2013-07-01 02:20:21 -0600 )edit

answered 2013-05-16 08:38:21 -0600

Vladislav Vinogradov gravatar image

It seems like CMake didn't find Visual Studio 11.

Which version do you have? Professional or Express?

Also GPU module have several issues on Visual Studio 11 (because CUDA doesn't officially support latest Visual Studio). It's better to use Visual Studio 2010.

edit flag offensive delete link more


I already got some steps further, by selecting the correct VS version and by manually selecting my C and CXX compiler locations. However, rest of configuration keeps giving me a hard time, see:

StevenPuttemans gravatar imageStevenPuttemans ( 2013-05-16 08:41:31 -0600 )edit

I have the professional VS2012 version. VS2010 unfortunately isn't an option. I don't necessarily need CUDA, I'm more interested in OpenCL support.

Ben gravatar imageBen ( 2013-05-16 08:47:11 -0600 )edit

Ben, I suggest you follow my topic posted. I got behind the step that gives you problems, and will put the solution in my topic!

StevenPuttemans gravatar imageStevenPuttemans ( 2013-05-16 08:49:27 -0600 )edit

How to do that in Linux . The way you manually selected the correct VS

Akshay Hazari gravatar imageAkshay Hazari ( 2017-08-29 01:56:37 -0600 )edit

answered 2013-05-16 06:12:43 -0600

Did you found a solution? Trying to tackle the same problem here!

edit flag offensive delete link more


Is that an answer or a comment? Thanks for pushing up this topic, anyway ;) No, I haven't found a solution to this yet. But I didn't investigate since then, as I had to focus on other things.

Ben gravatar imageBen ( 2013-05-16 06:58:46 -0600 )edit

Hmm excuse me, but it was intended to push up the topic :)

StevenPuttemans gravatar imageStevenPuttemans ( 2013-05-16 07:12:08 -0600 )edit

Question Tools


Asked: 2013-04-22 07:17:21 -0600

Seen: 3,333 times

Last updated: Jun 28 '13