Ask Your Question
1

2.4.3RC - Visual Studio 2012 - CUDA 5.0

asked 2012-10-30 17:01:03 -0500

jst42 gravatar image

Has anyone successfully compiled the 2.4.3 release candidate in MSVC-11 using CUDA 5.0, and if so how did you do it? I get this error message:

1>------ Build started: Project: opencv_core, Configuration: Debug x64 ------ 1> Building NVCC (Device) object modules/core/CMakeFiles/cuda_compile.dir/src/cuda/Debug/cuda_compile_generated_matrix_operations.cu.obj 1>nvcc : fatal error : nvcc cannot find a supported cl version. Only MSVC 9.0 and MSVC 10.0 are supported 1> CMake Error at cuda_compile_generated_matrix_operations.cu.obj.cmake:198

I have tried to explicitly identify usage of the MSVC-11 compiler in "nvcc.profile" and in "Cuda 5.0.props", but to no avail.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-12-14 09:13:02 -0500

ubehagelig gravatar image

I know you are trying to get CUDA 5.0 to work on VS2012, but if you can "live with" VS2010 and CUDA 4.3 it is quite easy to get working.

Check this guide: http://stackoverflow.com/questions/13228762/opencv-2-4-3rc-and-cuda-4-2-opencv-error-no-gpu-support

edit flag offensive delete link more
0

answered 2012-12-08 13:54:09 -0500

I have the similar problem. I'am waiting for the answer too.

edit flag offensive delete link more

Comments

Yep... similar problem ... I did find a very good blog (http://blog.norture.com/2012/10/gpu-parallel-programming-in-vs2012-with-nvidia-cuda/#comments) that has part of the problem solved ... just not my specific issue with some of the projects ... I've posted my issue there.

Doug_B gravatar imageDoug_B ( 2012-12-20 09:30:10 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-10-30 17:01:03 -0500

Seen: 3,917 times

Last updated: Dec 14 '12