Ask Your Question
1

Opencv 3.1 and Visual Studio 2015 (cannot open file 'opencv_calib3d310d.lib')

asked 2016-08-27 16:53:07 -0500

Nikolaos gravatar image

Hello there, I followed the Installation by Using the Pre-built Libraries article (I didn't make my Own Libraries from the Source Files), the Set the OpenCV enviroment variable and add it to the systems path article (the link to pathEditor was dead so I downloaded form somewhere else) and the How to build applications with OpenCV inside the "Microsoft Visual Studio" article using the local method, with the provided code example but I get an Error LNK1104 cannot open file 'opencv_calib3d300d.lib' . I really cannot understand where the problem is. I also noticed that

1 opencv_calib3d300d.lib

2 opencv_core300d.lib

3 opencv_features2d300d.lib

.....

lib files do not exist in my pre-built library. I'm on x64 platform in my Solution and in Debug mode, and logged in as administrator. Thank you.

edit retag flag offensive close merge delete

Comments

Have you tried 'start without Debugging''?

op gravatar imageop ( 2016-08-28 03:52:05 -0500 )edit

@op, please do NOT post answers, if you have a comment or question.

berak gravatar imageberak ( 2016-08-28 04:24:13 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-08-27 18:28:19 -0500

berak gravatar image

updated 2016-08-28 02:02:01 -0500

the prebuild packages come with a single opencv_world310.lib, which contains all calib3d, core,features2d, ... modules. please just link against that.

(also make sure, you use the "d" version for DEBUG build, and the one without for RELEASE)

edit flag offensive delete link more

Comments

thank you very much for your answer but after linking I get Loaded 'C:\Users\Administrator\Documents\Visual Studio 2015\Projects\ConsoleApplication1\x64\Debug\ConsoleApplication1.exe'. Symbols loaded.

'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\System32\ntdll.dll'. Cannot find or open the PDB file.

'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\System32\kernel32.dll'. Cannot find or open the PDB file.

'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\System32\KernelBase.dll'. Cannot find or open the PDB file.

'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\System32\vcruntime140d.dll'. Cannot find or open the PDB file.

'ConsoleApplication1.exe' (Win32): Loaded 'C:\Windows\System32\ucrtbased.dll'. Cannot find or open the PDB file

Nikolaos gravatar imageNikolaos ( 2016-08-28 01:48:56 -0500 )edit

I will try some windows/VS2015 specific search first for these issues and then I will give feedback.

Nikolaos gravatar imageNikolaos ( 2016-08-28 01:59:38 -0500 )edit
1

those are unrelated warnings. you're running in debug mode, and those pdb files are not present on your machine (because the dll's werent build there)

berak gravatar imageberak ( 2016-08-28 02:00:08 -0500 )edit
1

I managed to make it work, I copied opencv_world310.dll to project's directory and added opencv_world310.lid to additional dependencies. Thank you for your help!

Nikolaos gravatar imageNikolaos ( 2016-08-28 15:22:43 -0500 )edit

does such a method work if im using opencv version 2.4.13?

kentlow2002 gravatar imagekentlow2002 ( 2016-11-07 20:26:27 -0500 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-08-27 16:52:14 -0500

Seen: 11,875 times

Last updated: Aug 28 '16