Ask Your Question
0

Run-time Error Importing Caffe Models

asked 2016-08-16 02:43:59 -0500

BryceW gravatar image

updated 2016-08-16 03:09:45 -0500

When importing a caffe model I am getting the error convolution_layer.cpp:89:error:(-215) input.dims() ==4 && (input.type() == CV_32F || input.type() == CV_64F) in function cv::dnn::ConvolutionLayerImpl::allocate.

We never used to have this problem until recently we have rebuilt the libaries multiple times. We have had the program sucessfully run for quite some time importing and classifying with caffe models. However we lost the origional copies and as we reconstructed the new libaries this error has occured.

Issue has now been posted at this link: https://github.com/opencv/opencv_cont...

edit retag flag offensive close merge delete

Comments

try to make an issue here !

berak gravatar imageberak ( 2016-08-16 02:49:40 -0500 )edit

I just reconstuted the old libaries and it worked fine. I think its a problem with the new libaries.

BryceW gravatar imageBryceW ( 2016-08-17 05:58:07 -0500 )edit

@BryceW , can you try to find out the revision of the working snapshot ?

berak gravatar imageberak ( 2016-08-17 06:08:01 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-01 23:01:52 -0500

chibai gravatar image

try to use dnn::blob::fromImages(img) to load the image that may be helpful

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-16 02:43:59 -0500

Seen: 333 times

Last updated: Aug 16 '16