Ask Your Question
1

OpenCV 2.4.2 and trunk: cmake doesn't show CUDA options

asked 2012-07-21 16:39:59 -0500

Caroline gravatar image

I'm trying to compile OpenCV 2.4.2 or trunk with CUDA support on Ubuntu. On my machine, cmake does not list any of the CUDA options (such as WITH_CUDA, etc.) I'm running Lucid with a GeForce 550Ti card, driver version 302.17 and CUDA version 4.2.9. I've confirmed (using the CUDA SDK) that the gpu on my machine is up and running.

However, cmake does provide all of the CUDA options on another machine with the same graphics card, but running Ubuntu Precise, driver version 295.33 and CUDA toolkit 4.1.28.

Does OpenCV support the newest drivers and/or CUDA toolkits? Or could there be some other reason why cmake doesn't recognize CUDA on my machine?

edit retag flag offensive close merge delete

Comments

Ah, I have CMake 2.8.0, I'll try upgrading. Is there documentation somewhere that discusses system requirements for CUDA support? I couldn't find it. Thanks!

Caroline gravatar imageCaroline ( 2012-07-21 17:15:19 -0500 )edit

Upgrading cmake worked, thanks!

Caroline gravatar imageCaroline ( 2012-07-21 17:23:19 -0500 )edit

Please accept the answer, if it is working now. We will update OpenCV docs after restarting our dev site.

AlexanderShishkov gravatar imageAlexanderShishkov ( 2012-07-21 17:35:48 -0500 )edit

1 answer

Sort by » oldest newest most voted
3

answered 2012-07-21 16:54:31 -0500

AlexanderShishkov gravatar image

Please check version of your CMake. This option is unavailable for CMake versions <= 2.8

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-07-21 16:39:59 -0500

Seen: 621 times

Last updated: Jul 21 '12