Ask Your Question

jimfcarroll's profile - activity

2018-01-07 08:32:05 -0500 edited answer Java JNI “symbol lookup error” from custom native extension using OpenCV C++

This is currently intentionally the case. The controlling variable is CVAPI_EXPORTS set by CMake. If someone is interest

2018-01-07 08:31:46 -0500 answered a question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

This is currently the case intentionally. The controlling variable is CVAPI_EXPORTS set by CMake. If someone is interest

2018-01-07 08:01:48 -0500 received badge  Enthusiast
2018-01-06 16:41:30 -0500 edited question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

Java JNI “symbol lookup error” from custom native extension using OpenCV C++ I'm augmenting the Java wrapper for OpenCV

2018-01-06 16:40:28 -0500 edited question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

Java JNI “symbol lookup error” from custom native extension using OpenCV C++ I'm augmenting the Java wrapper for OpenCV

2018-01-06 16:40:13 -0500 edited question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

Java JNI “symbol lookup error” from custom native extension using OpenCV C++ I'm augmenting the Java wrapper for OpenCV

2018-01-06 16:39:46 -0500 edited question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

Java JNI “symbol lookup error” from custom native extension using OpenCV C++ I'm augmenting the Java wrapper for OpenCV

2018-01-05 08:20:02 -0500 edited question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

Java JNI “symbol lookup error” when I write my own native extention I'm augmenting the Java wrapper for OpenCV with some

2018-01-05 08:15:57 -0500 received badge  Editor (source)
2018-01-05 08:15:57 -0500 edited question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

Java JNI “symbol lookup error” when I write my own native extention I'm augmenting the Java wrapper for OpenCV with some

2018-01-05 08:13:32 -0500 asked a question Java JNI “symbol lookup error” from custom native extension using OpenCV C++

Java JNI “symbol lookup error” when I write my own native extention I'm augmenting the Java wrapper for OpenCV with some

2016-07-11 06:47:25 -0500 commented question Reading RGB jp2 image results in Red and Blue channels reversed

Thanks for the suggestions. I was pretty sure using the flag would work but unfortunately it didn't. If I write the image with OpenCV it works but if I had previously written it out it doesn't read it in correctly. I suppose it's possible the image is actually wrong but it reads in fine with ImageIO.

2016-07-09 10:41:07 -0500 asked a question Reading RGB jp2 image results in Red and Blue channels reversed

I'm using OpenCV 3.1.0 I'm calling it from Java.

When I read a jp2 file that was created using ImageIO I get an image with the red and blue channels reversed. When I open it using ImageIO ( https://github.com/jai-imageio/jai-im... ), it's fine. Is the opencv codec that loads the jp2 simply assuming the pixels are packed BGR rather than checking the relevant metadata?

I can fix this on a case by case basis by rewriting all of the images in memory before I do anything with them but this seems like a bug and I'd need to do it on an ad-hoc basis.

Thanks Jim