Ask Your Question

anauta's profile - activity

2016-11-04 08:38:12 -0500 received badge  Student (source)
2016-11-04 08:37:40 -0500 asked a question OpenCV reduce(), can I use median function?

Hi,

I have used the reduce() function often. From time to time I would like to use the median instead of min, max, avg, or sum. E.g I would need CV_REDUCE_MEDIAN.

I looked in the source code but could not find an easy way to accomplish this.

Can anyone help? Best regards, Auke

2013-03-05 08:01:26 -0500 asked a question CUDA compiler not invoked (nvcc)

Hi,

I cannot compile OpenCV (latest GIT sources) with CUDA 5.0 support. I have tried MANY things, yet the error is always the same:

For instance, when I want to build opencv_core, I get:

error LNK1181: cannot open input file 'build\modules\core\CMakeFiles\cuda_compile.dir\src\cuda\Debug\cuda_compile_generated_matrix_operations.cu.obj'

The cuda code is not being built. Also I do not see any reference of the nvcc compiler in the Output windows.

My system works fine otherwise: Clearing 'WITH_CUDA' makes everything build fine. Also, I can build and run the examples from CUDA 5.0 (both in 64 bit as well as 32 bit) without problems.

Can anyone help?

My system details: * Windows 7, core i7, 64 bit, 16GB RAM. * Visual Studio 2010 Premium * cMake 2.8.10.2

Note that in cMake, CUDA_SDK_ROOT_DIR is not found. However, when I tried to build with CUDA 4.2 (all cMake info appeared correct), the same error occurred...

2013-03-03 07:48:31 -0500 asked a question Compile OpenCV (from GIT) with CUDA 5.0

Hi,

I cannot compile OpenCV (latest GIT sources) with CUDA 5.0 support. I have tried MANY things, yet the error is always the same:

For instance, when I want to build opencv_core, I get:

error LNK1181: cannot open input file 'build\modules\core\CMakeFiles\cuda_compile.dir\src\cuda\Debug\cuda_compile_generated_matrix_operations.cu.obj'

It would seem that the cuda code is not being built :(

My system works fine otherwise. It compiles and runs the examples from CUDA 5.0 (both in 64 bit as well as 32 bit) without problems.

Can anyone help?

My system details: * Windows 7, core i7, 64 bit, 16GB RAM. * Visual Studio 2010 Premium * cMake 2.8.10.2

Note that is cMake, CUDA_SDK_ROOT_DIR is not found. However, when I tried to build with CUDA 4.2 (all cMake info appeared correct), the same error occurred...