Ask Your Question

TMiranda's profile - activity

2017-05-12 10:02:09 -0500 commented answer Build error Open CV3.2 with Extra Libs.

Yep, you're right. I've just downloaded opencv-3.2.0-rc and opencv_contrib-3.2.0-rc and everything has been configurated and installed just fine.

2017-05-12 08:46:13 -0500 commented answer Build error Open CV3.2 with Extra Libs.

What do you mean by updating cmake scripts?

2017-05-12 08:41:50 -0500 commented answer Build error Open CV3.2 with Extra Libs.

As soon as you download and configure protobuff, the Protobuf_LIBS will be updated with the currently installated location on your machine

2017-05-12 08:39:27 -0500 commented answer Cmake Errors

Thanks for the answer. In fact, I've downloaded protobuff from their github, but now I'm with errors on other downloads. It seems that my cmake+opencv cannot download dependencies. Anyway, I'll be unchecking all unnecessary modules from contrib.

2017-05-12 08:37:39 -0500 answered a question Build error Open CV3.2 with Extra Libs.

In fact, I was having the same problem. As mentioned before, it appears that OPENCV cannot download extra modules. I've solved it for protobuff by downloading remotely from their github, but you will find more errors on the way, probably.

My tip is: uncheck all unnecessary contrib modules. That will minimize the errors. Another option is trying to change the opencv installation location, but I don't know if that's going to work.

I'm using Ubuntu 16.04 and I'm currently with the same errors.

2017-05-10 12:42:39 -0500 asked a question Cmake Errors

Hi guys, I'm using CMAKE-GUI to configure and generate the files for installing OPENCV and link it with my Qt 5.8. I'm doing it on a Ubuntu 16.04 system, using opencv 3.2.0 and opencv_contrib 3.2.0

Apparently I'm having several errors related to the opencv_contrib usage. I've already Configurate OPENCV using CMAKE-GUI, without the CONTRIB modules and everything went all right. But I've tried to add the contrib modules a few times and was never able to do it. So, I've uninstalled everything and I'm doing it from the scratch.

I'm still having several errors and I didn't find any help to them so far. I'll be linking the several errors below.

CMake Error at .../opencv-3.2.0-source/cmake/OpenCVUtils.cmake:1005 (file): file MD5 failed to read file ".../opencv/opencv-3.2.0-debug/3rdparty/protobuf/": Sucess Call Stack (most recent call first): ../opencv_contrib-master/modules/dnn/cmake/OpenCVFindLibProtobuf.cmake:32 (ocv_download) ../opencv_contrib-master/modules/dnn/CMakeLists.txt:5 (include)

Downloading ... CMake Error at .../opencv-3.2.0-source/cmake/OpenCVUtils.cmake:1043 (file): file DOWNLOAD cannot open file for write. Call Stack (most recent call first): .../opencv_contrib-master/modules/dnn/cmake/OpenCVFindLibProtobuf.cmake:32 (ocv_download) .../opencv_contrib-master/modules/dnn/CMakeLists.txt:5 (include)

CMake Error at .../opencv-3.2.0-source/cmake/OpenCVUtils.cmake:1047 (message): Failed to download . Status= Call Stack (most recent call first): /h.../opencv_contrib-master/modules/dnn/cmake/OpenCVFindLibProtobuf.cmake:32 (ocv_download) .../opencv_contrib-master/modules/dnn/CMakeLists.txt:5 (include)