Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Incompatible library version: libopencv_sfm.3.1.dylib requires version 4.0.0 or later, but libgflags.2.dylib provides version 2.0.0

Hi everyone,

I've successfully upgraded to OpenCV 3.1 built and configured from source on my mac. When try to test the built libs I always get the following error (python for example)

(cv) sir:build sir$ python Python 2.7.10 (default, Jul 13 2015, 12:18:59) [GCC 4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.57)] on darwin Type "help", "copyright", "credits" or "license" for more information.

import cv2 Traceback (most recent call last): File "<stdin>", line 1, in <module> ImportError: dlopen(/Users/sir/.virtualenvs/cv/lib/python2.7/site-packages/cv2.so, 2): Library not loaded: /usr/local/lib/libgflags.2.dylib Referenced from: /usr/local/lib/libopencv_sfm.3.1.dylib Reason: Incompatible library version: libopencv_sfm.3.1.dylib requires version 4.0.0 or later, but libgflags.2.dylib provides version 2.0.0

Now, since there is no version 4.0.0 of libgflags I wonder what's going on?

Anyone has an idea?

I'd really appreciate it, since I cannot compile my OpenCV-Based projects anymore atm disaster help :)