Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

openCV 3.0 beta (source) + tbb

Hi there,

again a new post about compilation from openCV 3.0 master branch and tbb. Here is what I have done so far:

  • machine: win7, 32bits, visual studio 2013 (vc12)
  • set all path variables to openCV (code from master branch) and TBB (precompiled-win-zip)

    • ran cMake and activated with_tbb.
    • After configure, set the path to the relevant files (include-dirs, lib-dir, stddef-path)
    • my openCV folder is located at C:\Code\openCV3, my TBB folder C:\Code\tbb - is this a problem or must the tbb folder be included directly in the openCV folder?

    • added the tbb include and lib files to a property sheet and build openCV as debug (later as release). No errors, everything worked fine.

    • hit "install" including and linking to all files
    • in my test application compilation works, but at execution time, I am getting this failure:

"Failure in a procedure entry point" "?ge[email protected][email protected]@@[email protected]@[email protected] was not found in the dll opencv_world300d.dll"

I definitely deactivated WITH_CUDA and WITH_CUFFT in Cmake. So, why do I get this failure and what does "cuda" in this endless string mean? I have no CUDA graphics card and therefore deactivated these options, so I don't understand this problem.

Do you have a tip for me? Thank you so much, Johannes

openCV 3.0 beta (source) + tbb

Hi there,

again a new post about compilation from openCV 3.0 master branch and tbb. Here is what I have done so far:

  • machine: win7, 32bits, visual studio 2013 (vc12)
  • set all path variables to openCV (code from master branch) and TBB (precompiled-win-zip)

    • ran cMake and activated with_tbb.
    • After configure, set the path to the relevant files (include-dirs, lib-dir, stddef-path)
    • my openCV folder is located at C:\Code\openCV3, my TBB folder C:\Code\tbb - is this a problem or must the tbb folder be included directly in the openCV folder?

    • added the tbb include and lib files to a property sheet and build openCV as debug (later as release). No errors, everything worked fine.

    • hit "install" including and linking to all files
    • in my test application compilation works, but at execution time, I am getting this failure:

"Failure in a procedure entry point" "[email protected][email protected]@@[email protected]@[email protected] was not found in the dll opencv_world300d.dll"

I definitely deactivated WITH_CUDA and WITH_CUFFT in Cmake. So, why do I get this failure and what does "cuda" in this endless string mean? I have no CUDA graphics card and therefore deactivated these options, so I don't understand this problem.

Do you have a tip for me? Thank you so much, Johannes

openCV 3.0 beta (source) + tbb

Hi there,

again a new post about compilation from openCV 3.0 master branch and tbb. Here is what I have done so far:

  • machine: win7, 32bits, visual studio 2013 (vc12)
  • set all path variables to openCV (code from master branch) and TBB (precompiled-win-zip)

    • ran cMake and activated with_tbb.
    • After configure, set the path to the relevant files (include-dirs, lib-dir, stddef-path)
    • my openCV folder is located at C:\Code\openCV3, my TBB folder C:\Code\tbb - is this a problem or must the tbb folder be included directly in the openCV folder?

      • added the tbb include and lib files to a property sheet and build openCV as debug (later as release). No errors, everything worked fine.

    • hit "install" including and linking to all files
    • in my test application compilation works, but at execution time, I am getting this failure:

"Failure in a procedure entry point" "[email protected][email protected]@@[email protected]@[email protected] was not found in the dll opencv_world300d.dll"

I definitely deactivated WITH_CUDA and WITH_CUFFT in Cmake. So, why do I get this failure and what does "cuda" in this endless string mean? I have no CUDA graphics card and therefore deactivated these options, so I don't understand this problem.

Do you have a tip for me? Thank you so much, Johannes

openCV 3.0 beta (source) + tbb

Hi there,

again a new post about compilation from openCV 3.0 master branch and tbb. Here is what I have done so far:

  • machine: win7, 32bits, visual studio 2013 (vc12)
  • set all path variables to openCV (code from master branch) and TBB (precompiled-win-zip)
  • ran cMake and activated with_tbb.
  • After configure, set the path to the relevant files (include-dirs, lib-dir, stddef-path)
  • my openCV folder is located at C:\Code\openCV3, my TBB folder C:\Code\tbb - is this a problem or must the tbb folder be included directly in the openCV folder?

    • added the tbb include and lib files to a property sheet and build openCV as debug (later as release). No errors, everything worked fine.

  • hit "install" including and linking to all files
  • in my test application compilation works, but at execution time, I am getting this failure:

"Failure in a procedure entry point" "[email protected][email protected]@@[email protected]@[email protected] was not found in the dll opencv_world300d.dll"

I definitely deactivated WITH_CUDA and WITH_CUFFT in Cmake. So, why do I get this failure and what does "cuda" in this endless string mean? I have no CUDA graphics card and therefore deactivated these options, so I don't understand this problem.

Do you have a tip for me? Thank you so much, Johannes