Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Build problem to enable neon option

I am developing OpenCV on ARM ubuntu using Panda board. I build successfully OpenCV on Panda board as in following instruction: https://sites.google.com/site/andrewssobral/pandaboard

To enable NeOn instruction, I added following command to cmake/OpenCVCompilerOptions.cmake set(OPENCV_EXTRA_C_FLAGS "${OPENCV_EXTRA_C_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon") set(OPENCV_EXTRA_CXX_FLAGS "${OPENCV_EXTRA_CXX_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon")

I built successfully but when I run any test program after build OpenCV (for example: ./opencv_test_imgproc in bin directory). There is always an error: ./opencv_test_imgproc: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Than I export LD_LIBRARY_PATH to libstdc location. This error disappear but opencv_test_imgproc don't run any more without error.

Can you help me sold this problem? Can you teach me how to build OpenCV on Ubuntu using Panda board with NeOn option is enable?

Build problem to enable neon option

I am developing OpenCV on ARM ubuntu using Panda board. I build successfully OpenCV on Panda board as in following instruction: https://sites.google.com/site/andrewssobral/pandaboard

To enable NeOn instruction, I added following command to cmake/OpenCVCompilerOptions.cmake cmake/OpenCVCompilerOptions.cmake

set(OPENCV_EXTRA_C_FLAGS "${OPENCV_EXTRA_C_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon") -mfpu=neon")

set(OPENCV_EXTRA_CXX_FLAGS "${OPENCV_EXTRA_CXX_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon")

I built successfully but when I run any test program after build OpenCV (for example: ./opencv_test_imgproc in bin directory). There is always an error: ./opencv_test_imgproc: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Than I export LD_LIBRARY_PATH to libstdc location. This error disappear but opencv_test_imgproc don't run any more without error.

Can you help me sold this problem? Can you teach me how to build OpenCV on Ubuntu using Panda board with NeOn option is enable?

Build problem to enable neon optionNeOn option on ARM Ubuntu

I am developing OpenCV on ARM ubuntu using Panda board. I build successfully OpenCV on Panda board as in following instruction: https://sites.google.com/site/andrewssobral/pandaboard

To enable NeOn instruction, I added following command to cmake/OpenCVCompilerOptions.cmake

set(OPENCV_EXTRA_C_FLAGS "${OPENCV_EXTRA_C_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon")

set(OPENCV_EXTRA_CXX_FLAGS "${OPENCV_EXTRA_CXX_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon")

I built successfully but when I run any test program after build OpenCV (for example: ./opencv_test_imgproc in bin directory). There is always an error: ./opencv_test_imgproc: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Than I export LD_LIBRARY_PATH to libstdc location. This error disappear but opencv_test_imgproc don't run any more without error.

Can you help me sold this problem? Can you teach me how to build OpenCV on Ubuntu using Panda board with NeOn option is enable?

Build problem to enable NeOn option on ARM Ubuntu

I am developing OpenCV on ARM ubuntu using Panda board. I build successfully OpenCV on Panda board as in following instruction: https://sites.google.com/site/andrewssobral/pandaboard

To enable NeOn instruction, I added following command to cmake/OpenCVCompilerOptions.cmake

set(OPENCV_EXTRA_C_FLAGS "${OPENCV_EXTRA_C_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon")

set(OPENCV_EXTRA_CXX_FLAGS "${OPENCV_EXTRA_CXX_FLAGS} -Wa,-a,-ad -mfloat-abi=softfp -mfpu=neon")

I built successfully but when I run any test program after build OpenCV (for example: ./opencv_test_imgproc in bin directory). There is always an error: ./opencv_test_imgproc: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Than I export LD_LIBRARY_PATH to libstdc location. This error disappear but opencv_test_imgproc don't run any more without error.

Can you help me sold solve this problem? Can you teach me how to build OpenCV on Ubuntu using Panda board with NeOn option is enable?