Ask Your Question

VideoCapture problem - Inappropriate ioctl for device

asked 2016-08-05 12:17:32 -0500

thxmxx gravatar image

I'm trying to open a video

VideoCapture video_source; 
video_source = VideoCapture();"/home/thom/Downloads/output.mp4");

and I'm getting this message:

Unable to stop the stream: Inappropriate ioctl for device Could not open the stream file.

Any clue?

edit retag flag offensive close merge delete


I am having a similar problem after installing on CentOS. cmake/installation completes without any errors.

import cv2 cv2.VideoCapture('path/to/video')

Unable to stop the stream: Inappropriate ioctl for device

danMorozoff gravatar imagedanMorozoff ( 2017-01-14 16:12:15 -0500 )edit

same problem here anyone give us a hint?My system is CentOS 6 GCC 4.8.2 OPENCV 3.2

open_ranger gravatar imageopen_ranger ( 2017-02-10 09:15:44 -0500 )edit

Same here. Debian 7 and contrib_modules installed.

Argos gravatar imageArgos ( 2017-03-29 03:43:03 -0500 )edit

Same for me. Centos7 OpenCV 3.2...

sylweb gravatar imagesylweb ( 2017-04-13 03:04:17 -0500 )edit

Having same problem. Can anyone help? OpenCV 3.2, Ubuntu 17.04

Aritra gravatar imageAritra ( 2017-10-03 12:01:40 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2017-04-13 03:16:54 -0500

sylweb gravatar image

Maybe this might not be the best answer but it worked for me for OpenCV 3.1 instead of 3.2

edit flag offensive delete link more



how to solve this issue :Unable to stop the stream: Inappropriate ioctl for device

aditya2695 gravatar imageaditya2695 ( 2017-05-24 11:50:56 -0500 )edit

answered 2018-05-09 08:28:34 -0500

Mary-Ann gravatar image

Take a look at this thread: , it solved the problem my similar me. Basically you only need to rebuild OpenCV with FFMPEG and it should work.

edit flag offensive delete link more

Question Tools



Asked: 2016-08-05 12:17:32 -0500

Seen: 13,134 times

Last updated: May 09 '18