Ask Your Question
0

Error when compiling videoio/src/cap_ffmpeg_impl.hpp

asked 2016-04-16 13:14:14 -0500

MrGiskard gravatar image

I am compiling opencv 3.0.0 but I get multiple "xxx was not declared in this scope" errors when compiling cap_ffmpeg_impl.hpp file. (E.g pix_fmt_yuv422p, codec_pix_fmt) I have built ffmpeg using the --enable-shared option (as advised on other forums) and ffmpeg appears to run without any problems.

If a patch has been issued for this please let me know. Any help would be greatly appreciated

edit retag flag offensive close merge delete

Comments

  • can you give us the exact error msges ?
  • which os / compiler is it ?
  • can you try latest github master src, instead of opencv3.0 (which is already half a year away)
berak gravatar imageberak ( 2016-04-16 13:22:34 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-17 03:27:00 -0500

MrGiskard gravatar image

I used 3.0 because I don't have much experience with linux and the tutorials I had found used that. Turns out that using 3.1 made the problem go away - the compilation completed OK. Thanks for your help

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-04-16 13:14:14 -0500

Seen: 143 times

Last updated: Apr 16 '16