surface_matching installation problem

asked 2016-04-14 03:28:36 -0500

gino0717 gravatar image

Hi, I'm testing the new funtion of opencv 3.1 and install the opencv_contrib, I copy the surface_matching folder and paste to the original opencv folder and use CMAKE to build it for Visual Studio 2012. After that, I setup the lib and copy the code in the tutorial: http://docs.opencv.org/3.0-beta/modul...

all compiled good but when I run the code,it always shows error: "The procedure entry point ?writePLY@ppf_match_3d@cv@@YAXVMat@2@PEBD@Z could not be located in the dynamic link library"

just like the picture: image description

It only happened when I used the surface_matching function, What did I miss when I installed? thanks for your replying

edit retag flag offensive close merge delete

Comments

please do not send screenshots, but text (so folks can google it, your problem can be properly indexed, etc.)

berak gravatar imageberak ( 2016-04-14 03:49:13 -0500 )edit

there is the text

gino0717 gravatar imagegino0717 ( 2016-04-14 03:55:26 -0500 )edit

yea, sorry. just saying ..

berak gravatar imageberak ( 2016-04-14 03:58:33 -0500 )edit

I tried opencv3.0.0 instead of opencv3.1.0 and seems work. I think the problem may be that the openCV_contrib did not update to the lastest version. However, since the newest update time of the module is about months ago after opencv3.1.0 released, I doubt this conclusion.I'll keep trying to build it in opencv 3.1.0 version and find other solution. I just leave the message here for someone who may have same problem but can only get the answer like "update your opencv to newest version"

gino0717 gravatar imagegino0717 ( 2016-04-14 21:59:11 -0500 )edit