OpenCV with OpenCL/CUDA oclMat/GpuMat doesn't work

asked 2016-03-08 15:11:19 -0500

Rike gravatar image

Hello to everyone,

I'm trying to run OpenCVs calcOpticalFlowPyrLK on my GPU. I'm using Visual Studio 2012 and OpenCL 2.4.10 because OpenCV 3.0 doesn't work fine. I tried it one one PC with a AMD Radeon and also on a Laptop with an NVIDIA Geforce.

At first i tried it with OpenCL. Included this: #include "<"opencv2\ocl\ocl.hpp">" When I try to declare the oclMat Variable and scroll the mouse over it, it says: computes element-wise minimum of the two arrays (dst=min(src1,src2))

It also says: ";" expected when i scroll over the name I wanted to give my oclMat Object.

Then I tried everything with CUDA and it was nearly the same.

Does someone have an idea? Which Versions of what do I have to install?

Thank you for your help! PS: Sorry for the bad formatting

edit retag flag offensive close merge delete

Comments

Does your GPU support CUDA ? Did you install CUDA tool kit and test CUDA sample programs like deviceQuery?

MarKS9 gravatar imageMarKS9 ( 2016-03-08 15:44:44 -0500 )edit
  • [...] because OpenCV 3.0 doesn't work fine -> I may agree to such statement to a certain degree, but I honestly think you didn't even try it
  • Clearly seems like your problems are related to programming issues having nothing to do with ocl or gpu
  • You'd better update your post with your code if you really want us to give a try
LorenaGdL gravatar imageLorenaGdL ( 2016-03-08 15:58:23 -0500 )edit

Do you mean something like this https://devblogs.nvidia.com/parallelf... I'm sorry I don't have any experience with CUDA

Rike gravatar imageRike ( 2016-03-08 16:01:14 -0500 )edit