Ask Your Question
0

No Makefile to build after cmake

asked 2016-03-02 03:32:08 -0500

lianguage gravatar image

Hi Guys

Sorry if this has been discussed before, but I can't find any info on it. I'm having trouble installing cmake to ubuntu 14.04

I've tried cloning from the github repo and downloading the zip directly from the cmake homepage.

My cmake version is:2.8.12.2 The version of OpenCV downloaded is: 3.1.0

The error is that when I follow the steps to install it, the directory that cmake builds to does not contain a makefile, and so running the 'make' command does not work. returning an error:

make: * No targets specified and no makefile found. Stop.

Any clues as to why this is the case?

Thanks!

edit retag flag offensive close merge delete

Comments

do you have trouble building cmake or opencv ?

berak gravatar imageberak ( 2016-03-02 03:40:37 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-03-02 03:44:12 -0500

strann gravatar image

There should be no problems. Try following

sudo apt-get install -y unzip wget
wget https://github.com/Itseez/opencv/archive/master.zip
unzip master.zip
rm master.zip

cd opencv-master
mkdir build
cd build
cmake ..
make -j4
sudo make install
sudo ldconfig
edit flag offensive delete link more

Comments

Wow that worked... what the heck? I was following a guide from: http://docs.opencv.org/2.4/doc/tutori... When I cloned from the git link provided in the guide, it did not build the way it did with your link...

Thanks so much! (currently building :D)

lianguage gravatar imagelianguage ( 2016-03-03 02:36:30 -0500 )edit

dude, installing opencv master didn't solve my problem though! I'm trying to add surf and sift feature extractions from opencv contribution to opencv master but 'make' command still complains :

make *** no targets specified and no makefile found. stop.
Farid gravatar imageFarid ( 2018-04-06 05:50:01 -0500 )edit

I am also still struggling with the above. Did you find a resolution?

Alexandrei gravatar imageAlexandrei ( 2019-02-14 22:43:58 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-02 03:32:08 -0500

Seen: 7,392 times

Last updated: Mar 02 '16