Ask Your Question
0

package 'tbb' not found in opencv 3.1.0 Linux(Solved)

asked 2016-02-16 06:47:54 -0500

updated 2016-02-19 05:07:09 -0500

Hello,

I am cross compiling OpenCV 3.1.0 with TBB for raspberry pi arm architecture but when I configure cmake, It shows me following warnings.

checking for module 'tbb' package 'tbb' not found

Not sure why If I already set include, stddef.h and lib path. If any have any idea about it, Kindly share it with me. I will appreciate your help.

Thanks

Tushar Kachhadiya

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-02-18 03:12:57 -0500

kbarni gravatar image

updated 2016-02-18 03:15:57 -0500

Are you sure you have TBB (libtbb and libtbb-dev) installed on the Raspberry Pi?

Normally they are not in the Debian repositories and they are difficult to build for the Rasp (you need an unofficial Debian armhf to run it).

You didn't specify the Raspberry Pi model you are using, but multithreading makes sense only on the Pi 2 with multicore processor.

I suggest to use OpenCV without TBB. It compiles and works without problems on the Raspberry Pi.

If you absolutely need TBB, you have to build it yourself on your cross-compilation chain. Check the TBB forums for help.

edit flag offensive delete link more

Comments

Hi

I have successfully build TBB with OpenCV 2.4.9 in RaspberryPi2 for arm architecture using Raspbian GCC 4.9.

Thanks,

Tushar Kachhadiya

Tushar Kachhadiya gravatar imageTushar Kachhadiya ( 2016-02-19 05:05:14 -0500 )edit

It seems your CMAKE is not able to find the proper paths to your TBB installation. Use explicit commands to set the paths using CMAKE-GUI or by looking for corresponding CMAKE command.

StevenPuttemans gravatar imageStevenPuttemans ( 2016-02-19 06:17:15 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-02-16 06:47:54 -0500

Seen: 817 times

Last updated: Feb 19 '16