Ask Your Question

unresolved external symbol : xfeatures2d problem with SIFT

asked 2016-02-08 03:47:51 -0500

AdamIB gravatar image


I've a problem related to SIFT, when I try to build my program I got this error

unresolved external symbol public static struct cv::Ptr <class cv::xfeatures2d::sift="">

regarding to opencv librarries I have defined these two only

opencv_ts300d.lib opencv_world300d.lib

so does the problem related to the missing xfeatures2d.lib? although I have the folder xfeatured and file xfeatured.cpp

On the other hand, if you ask me about cmake: In fact I have tried to build xfeatures.lib but I got error it says that xfeatures2d.lib is missing

So, any help will be appreicated :)

edit retag flag offensive close merge delete



i guess, you have to start from scratch here. since using the contrib repo requres tight synchronization regarding versions, you'll have to get opencv & opencv_contrib src from github, and rebuild the whole thing, cmake, build, build INSTALL . see contrib readme

berak gravatar imageberak ( 2016-02-08 03:54:38 -0500 )edit

hi berak, and thank you for your reply, so I have the OPENCV 3 and contrib that i got it from , can you tell me which version of OPENCV i should have?

AdamIB gravatar imageAdamIB ( 2016-02-08 03:57:57 -0500 )edit

that's an easy answer: latest ;) (for both)

(e.g. hal was moved back into core in 3.1, so you can't build opencv3.0 with recent contrib)

berak gravatar imageberak ( 2016-02-08 04:02:40 -0500 )edit

ok , I've downloaded the latest for both and when I try to compile it in cmake (new version of opencv) it says "Failed to download opencv_ffmpeg.dll. Status=7;"Couldn't connect to server" is there any ideas? thx

AdamIB gravatar imageAdamIB ( 2016-02-08 13:31:04 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-02-14 23:27:35 -0500

AdamIB gravatar image

OK i have solved the problem by using the old version of OPENCV 3 and contrib 3 so it works now

edit flag offensive delete link more


how to do it?

devansh20la gravatar imagedevansh20la ( 2016-02-15 16:26:16 -0500 )edit

ok you need to get OpenCV3 and Opencv_contrib 3 (same version), it's difficult to get it from the github because now it's build using opencv3.1, but just try opencv 3.1 and opencv_contrib 3.1 you might get a good result and don't forget to have a proper disk space as well, cheers

AdamIB gravatar imageAdamIB ( 2016-02-16 23:51:39 -0500 )edit

hi adamIB

i try to install opencv3 for my project with extra module (i want to use sift algorithm for image processing) but i cannot configure cmake with contrib (contain feature2d) ..i got error "CMake Error at cmake/OpenCVModule.cmake:277 (add_subdirectory):

The binary directory C:/opencv/build/modules/calib3d/.calib3d" and for other modules "core,cudaarithm,cudabgsegm,cudacodec,cudacodec,cudafeatures2d,cudafilters,cudaimgproc,cudalegacy,cudaobjdetect,cudaoptflow,cudastereo,cudawarping,cudev,features2d,flann,highgui,imgcodecs, etc.)

Amir.t gravatar imageAmir.t ( 2016-05-18 03:30:10 -0500 )edit

Question Tools

1 follower


Asked: 2016-02-08 03:47:51 -0500

Seen: 961 times

Last updated: Feb 14 '16