Is there a good tutorial for installing opencv 3.1 with Visual Studio 2015?

asked 2016-02-06 16:06:12 -0500

jonjacson gravatar image

Hi folks,

I want to learn this but I am having trouble configuring Visual Studio to work together with OpenCV.

I found this link:

http://docs.opencv.org/2.4/doc/tutori...

But it is for Visual Studio 2010 and I guess some options have changed.

In youtube I found tutorials for setting properly Visual Studio the problem is there is a step where they use this address:

C:/Installation folder/OpenCV/lib

But in my local installation I cannot find any lib folder inside OpenCv.

So, Does anybody know how to properly configure Microsoft Visual Studio 2015 with OpenCV 3.1?

I am using Windows 7.

Thanks!

edit retag flag offensive close merge delete

Comments

Are you installing by compiling the source or using the download? If you're compiling the source, the lib folder will be in the output from that. If you're downloading the installer, it should be there.

Tetragramm gravatar imageTetragramm ( 2016-02-06 16:45:11 -0500 )edit

Hi Tetragramm, thanks for your answer. I upload a capture so you can see the same as me.

link text

The first capture is inside OpenCV, then inside Build and then Inside Sources. I don't see the Lib folder.

I am downloading the installer.

jonjacson gravatar imagejonjacson ( 2016-02-06 17:05:29 -0500 )edit

Ah, I think it's inside build/x64/ somewhere in there is the lib folder. The exact folders in there depend on a couple of things, for example, I build from source, so my path is x64/vc14/lib

Tetragramm gravatar imageTetragramm ( 2016-02-06 17:34:25 -0500 )edit

Thank you very much!

jonjacson gravatar imagejonjacson ( 2016-02-06 17:43:56 -0500 )edit