Ask Your Question

Not able to install openCV on raspberry pi 2 model B (jessie)

asked 2016-01-31 04:15:00 -0600

shivam gravatar image

updated 2018-11-16 09:50:22 -0600

Hi all,

I am trying to install openCV 2.4.9 on raspberry pi 2 but facing some error regarding libtiff4-dev image format.

image description

I have tried with 'libtiff5-dev' also but it is not working.

image description

I dont know what the issue is, I installed same openCV in my other micro SD card 3-4 month before that time it worked fine.

I have already install python 2.7.9.

I have tried searching for this error, found few links but not sure if that is correct or not

but was not able to find a solution, can anyone help me? Tell me what wrong I am doing here or how to proceed from here.

Thanks in advance.

edit retag flag offensive close merge delete


found this link maybe it can help

shivam gravatar imageshivam ( 2016-01-31 04:17:09 -0600 )edit

You have to install libjpeg-dev and libtiff5-dev.

The problem might be that libjpeg-dev installs libjpeg62-turbo-dev, not libjped8-dev.

Anyway, I think it's much easier to manage the packages with Synaptic than by copy-pasting apt-get commands.

N.B. libtbb2 is not available for Raspbian and it's quite complicated to compile it; you have to build OpenCV without it...

kbarni gravatar imagekbarni ( 2016-02-01 03:04:12 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-05-21 18:46:47 -0600

easy to solve. I also had problems with this one. sudo apt-get install libtiff5-dev

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-01-31 04:15:00 -0600

Seen: 973 times

Last updated: Jan 31 '16