Lib folder is (almost) empty?

asked 2016-01-26 16:52:56 -0500

Vaaal gravatar image

Hello guys, I am completely new to OpenCV and I was trying to set it up for the first time. I am on Windows 7 64bit and using Visual Studio 2013. I first tried with Open CV 301 by usign this tutorial http://docs.opencv.org/2.4/doc/tutori... The problem is that my system canno find opencv_calib3d301.lib, and of course it cant'! The folder C:\opencv\build\x64\vc12\lib is almost completely empty! Does not contain all the required library, but only some opencv_ts301.lib files.

Then I tried to download the 3.0.0 as it is the one the tutorial is referring to. Well, the same! Lib folder does not contain the required files: image description

However, in build\x64\vc12 there was another folder apart from bin and lib, which was staticlib, which contains ALL THE LIBRARIES that I needed. End of story? Not really, even after selecting this folder for all the dependencies, I still get some problem.

I think that the main mistery, here, is why I don't get all those files in the lib folder. I went to several online tutorial and no one mentioned this problem, which is really weird. Am I missing something?

Thank you for your help

edit retag flag offensive close merge delete

Comments

1

I suggest you change to opencv 2.4.11. It includes all the library you need. You just need to link the required library to VS 2013. The debug libraries are ended with xxxd.lib. You could make a try in debug mode first. Take a reference to this link(https://marcomuraresearch.wordpress.c...)

cv_new gravatar imagecv_new ( 2016-01-27 04:11:17 -0500 )edit

thank you!

Vaaal gravatar imageVaaal ( 2016-01-28 07:43:42 -0500 )edit