Beaglebone Opencv: cam.read() throws error and timeout

asked 2016-01-23 08:02:56 -0500

luketheduke gravatar image

Hi All, I am running OpenCV on a Beaglebone Black with Ubuntu. After I installed it I tried importing it into python. That all worked so I tried to capture video from a USB Webcam. I can run the command cap = cv2.VideoCapture(0) but when I then run ret, frame = cap.read() it sits there for thirty seconds and then prints all this out:

select timeout
select timeout
OpenCV Error: Assertion failed (total() == 0 || data != NULL) in Mat, file /home/ubuntu/opencv/modules/core/include/opencv2/core/mat.inl.hpp, line 410
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
cv2.error: /home/ubuntu/opencv/modules/core/include/opencv2/core/mat.inl.hpp:410: error: (-215) total() == 0 || data != NULL in function Mat

Everything I've searched for has come up empty, any ideas? Thanks,

edit retag flag offensive close merge delete

Comments

Hi, did you try to use cheese (sudo apt-get install cheese) with the same camera and board? I got the same error in python. Cheese said: https://pastebin.com/dJ34vU4R, so maybe we should fix the cheese's problem. I'm using Mint on VM. The camera works perfect on my windows.

Orian Zinger gravatar imageOrian Zinger ( 2018-01-20 17:51:49 -0500 )edit