Ask Your Question

OpenCV 3.1 issue on iOS9 (arm64)

asked 2015-12-28 11:53:59 -0500


I tried to upgrade my iOS app from OpenCV 3.0 to OpenCV 3.1, and when I try to build it gives me this error:

Screen Shot 2015-12-28 at 17.42.40.png

I just downloaded the framework from sourceforge, any idea what can I do to fix this issue?

Thanks in advance.

edit retag flag offensive close merge delete


Were you able to solve this? I am having the exact same issue

jadfei gravatar imagejadfei ( 2016-01-11 10:48:19 -0500 )edit


I have found that this issue is to do with libpng.a This link has a solution however I am unable to build the source code at the moment.

aussiDavid gravatar imageaussiDavid ( 2016-01-15 21:52:34 -0500 )edit

Why not just download the iOS framework and add it to your frameworks? It is already built. I have completed a test project in Xcode using opencv 3.1. El Capitan 10.11.3, Xcode 7.2. No Swift yet, but I believe it will work. Works fine with Obj C.

jmbapps gravatar imagejmbapps ( 2016-01-27 13:32:02 -0500 )edit

I am facing the same problem. Does anyone have a solution? Thx, Florian

Florian1980 gravatar imageFlorian1980 ( 2016-05-13 09:12:33 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-08-19 15:36:31 -0500

This _png_init_filter_functions_neon "undefined symbols for architecture arm64" issue is fixed by this commit, I think:

Effectively, -DENABLE_NEON=ON is incorrectly skipped on arm64 during the build before this commit.

See my answer at StackOverflow for more details:

To minimize risk, I cloned, checked out the 3.1.0 tag, and cherry-picked just the 262a52fcommit, and have built with that using instructions from -- this appears to have worked.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2015-12-28 11:53:59 -0500

Seen: 963 times

Last updated: Dec 28 '15