Ask Your Question
0

Build errors with OpenCV4Android samples in Eclipse

asked 2012-07-26 08:00:17 -0500

ab_lyn gravatar image

updated 2012-07-29 01:45:19 -0500

Kirill Kornyakov gravatar image

I can't successfully run the opencv sample programs. I have followed the configuration steps but continue to have this error:

[2012-07-26 13:34:49 - OpenCV Sample - 15-puzzle] OpenCV Sample - 15-puzzle does not specify a android.test.InstrumentationTestRunner instrumentation or does not declare uses-library android.test.runner in its AndroidManifest.xml

SInce Android 2.3.3 is API 10 and API 11 or higher is required I selected configured samples for Android 4.0 API 15, (using Galaxy s2)

what's wrong and how can I sort this out. Many thanks

edit retag flag offensive close merge delete

Comments

When are you getting this error? If this is while you're executing the app from Eclipse, I suspect that you've chosen wrong item of the context menu. Eclipse is thinking that your app is a JUnit application...

Kirill Kornyakov gravatar imageKirill Kornyakov ( 2012-07-26 11:09:18 -0500 )edit

Yes, while executing the app from Eclipse Which context menu? if u are reffering to project, I normally would have selected 'Android project' How can I fix this?

ab_lyn gravatar imageab_lyn ( 2012-07-26 11:57:42 -0500 )edit

hey guys please dont ignore my question. I am desperate. Surely someone (experts in this area) can interpret the error i am having. I don't know what 'JUnit' of the previous comment (Kirill Kornyakov) meant.. Pls this is urgent

ab_lyn gravatar imageab_lyn ( 2012-07-26 16:14:53 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-08-09 03:19:52 -0500

Kirill Kornyakov gravatar image

Sorry, but I don't know what is your problem. I'm still thinking that you're pressing a wrong button, check if you're choosing the first item in this list (http://docs.opencv.org/_images/eclipse_11_run_as.png). This is from the first OpenCV4Android tutorial: http://docs.opencv.org/doc/tutorials/introduction/android_binary_package/android_binary_package.html#android-binary-package. android.test.InstrumentationTestRunner is required if you're executing test application, which is second item in the list above (Android JUnit Test). So, you're either choosing a wrong button, or did something bad to the sample...

BTW, you have to study JUnut, because it is de-facto standard for Unit-tests. You can start here: http://developer.android.com/tools/testing/index.html

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-07-26 08:00:17 -0500

Seen: 345 times

Last updated: Aug 09 '12