Getting build/source files?

asked 2015-12-15 23:58:30 -0600

BartBB gravatar image

updated 2015-12-18 13:20:02 -0600

I'm following a guide of how to connect OpenCV to CodeBlocks and in one of the steps, I am supposed to use CMake to build the binary files, or something like that. (New to all this tbh, but I need this badly so I'm not giving up)

While following this file something didn't fit to the guide, so I asked online and they referred me to another guide, which tells me to use TortoiseGit and get the source files, or build files, idk. But when I use the provided link, TortoiseGit crashes.

So.. my question is.. what do I do? Anyone know another link? Perhaps the given one is not functional anymore. Or maybe another way of doing this?

Maybe I already have the source files somewhere? Anything at all will do, really.

Thank you in advance.

EDIT: After running CMake, my lib and bin folders are still empty in the destination "Where to build the binaries". I have no idea why or how to fix this, if anyone does.. I will really appreciate it.

edit retag flag offensive close merge delete



"so I'm not giving up" - ++ !!

if git is too much for you, you can get a zip file of the opencv code, either the master(3.0) or the 2.4 branch

berak gravatar imageberak ( 2015-12-16 01:02:20 -0600 )edit

Alright, so.. I've downloaded what you linked the master(3.0) one and used CMake. It all went smoothly until the moment it nearly finished generating the files or whatever CMake does. Then I got loads or red messages. Warnings to be precise. Thought I could ignore it and give it a shot, went to the destination folder and went inside then to the bin folder inside of it and it was empty. I'm unsure about whether that's alright or not (Seems not good to me) and I'm gonna follow the first guide from this point and see if it works.

I hope it works, but I honestly quite doubt it.

EDIT: Ye.. something still doesn't work. Most if not all folders in the mingw folder do not have any files in them.

BartBB gravatar imageBartBB ( 2015-12-16 03:59:36 -0600 )edit

ok, can you re-run cmake, and append the output to your question (it will be rather long) ?

berak gravatar imageberak ( 2015-12-16 07:14:18 -0600 )edit

I have ran it once again, even before you asked me to. I don't know what changed but this time everything was successful except for a few things which require python (which I am just about to configure and then try again) if it doesn't work I will be sure to let you know.

BartBB gravatar imageBartBB ( 2015-12-16 07:45:14 -0600 )edit

if you get it to work , it would be nice to have your receipe .. ;)

berak gravatar imageberak ( 2015-12-16 08:17:45 -0600 )edit

I have installed python using the python windows executable installer but when I ran CMake it gave me the same errors. I must be doing something wrong. I'm going to search online, but I'll still leave this here, perhaps I won't find a solution (which I highly doubt) and you know it.

Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "2.7") Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "2.6") Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "3.4") Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "3.2")

BartBB gravatar imageBartBB ( 2015-12-16 12:19:27 -0600 )edit

Fixed those specific errors yet my lib and bin folders in the destination of CMake are still empty. Any clue?

BartBB gravatar imageBartBB ( 2015-12-18 13:18:42 -0600 )edit

you have to build the INSTALL project in release mode (it's not done automatically)

berak gravatar imageberak ( 2015-12-19 01:17:49 -0600 )edit

What do you mean by that? I don't quite understand how that is done. I still haven't been able to configure OpenCV with CodeBlocks.

BartBB gravatar imageBartBB ( 2015-12-19 02:08:08 -0600 )edit

sorry i meant make install in this case.(using mingw).

and the files will show up in "build/install" (or whatever you set CMAKE_INSTALL_PREFIX to)

berak gravatar imageberak ( 2015-12-19 02:39:18 -0600 )edit