Ask Your Question
0

[SOLVED] Accessing IP Camera Feed

asked 2015-12-13 21:56:56 -0500

roahanramesh gravatar image

updated 2015-12-14 06:26:36 -0500

Hi All, Thanks for taking time to view my post. I have been trying for several days to access feed from an IP Camera. Mentioned below are my code and the steps that i have done thus far, based upon information received in the forums.

  1. IP Camera Make : Vstarcam ; Model Number : T7892WIP ; Based upon the information on the website (iSpy) the details for accessing the ip camera are given below

T7892WIP MJPEG (Image Format)

http://IPADDRESS:554/videostream.cgi?...

  1. Platform Windows 7 (32 bit) + OPENCV 2.4.5 and Qt 5.4.1

  2. Code

capture.open("http://192.168.1.50:8080/videostream.cgiuser=admin&pwd=888888&resolution=32&rate=10.mpeg"); if(!capture.isOpened()) { qDebug()<<"Cannot Open Camera"; exit(1); } else { //Capture Frame and Process }

When i try to execute the above code, I get the following message

Cannot Open Camera warning: Error opening file (../../modules/highgui/src/cap_ffmpeg_impl.hpp:529).

  1. Steps that i have followed

a). I used iSpy software to get the IP camera link and used the same. I am able to open the IP Camera Feed on the web-browser and iSpy software as well. Both are working without any issues.

b). Used the same link and opened in VLC Media Player and that too is able to open the video feed.

c). I replaced the url with 0, to detect the default camera, and the webcam is detecting and displaying the image correctly.

Please Help.

edit retag flag offensive close merge delete

Comments

why you are using different URL/PORT ? Based upon the information on the website you should use 554 instead of 8080: capture.open("http://192.168.1.50:554/videostream.cgi?user...")

pklab gravatar imagepklab ( 2015-12-14 05:22:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-12-14 06:25:56 -0500

roahanramesh gravatar image

Thanks pklab, for your reply, Tried that, It worked. Also did the alternate, where in i used the original port that i used, which is 8080.

The issue was the .mpeg at the very end of the url. I changed it to .mjpg and it worked like a charm.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-12-13 21:56:56 -0500

Seen: 5,711 times

Last updated: Dec 14 '15