Ask Your Question
0

FilterEngine is not a member of cv but imgproc.hpp was included

asked 2015-12-07 10:00:01 -0500

YangTL gravatar image

I was trying to build the Face detection code here C++ implementation of Deva Ramanan's "Articulated Pose Estimation with Flexible Mixtures of Parts". But I ran into some problem

In file included from /home/richardyang/Documents/OpencvProject/Final/PartsBasedDetector/include/DepthConsistency.hpp:44:0, from /home/richardyang/Documents/OpencvProject/Final/PartsBasedDetector/src/DepthConsistency.cpp:39: /home/richardyang/Documents/OpencvProject/Final/PartsBasedDetector/include/types.hpp:56:29: error: ‘FilterEngine’ is not a member of ‘cv’ typedef std::vector<cv::ptr<cv::filterengine> > vectorFilterEngine;

But the file include every library it need.

#ifndef TYPES_HPP_
#define TYPES_HPP_
#include <vector>
#include <opencv2/core/core.hpp>
#include <opencv2/imgproc/imgproc.hpp>
class MatlabIOContainer;
class Candidate;

// common typedefs
// 1D
typedef std::vector<int>            vectori;
typedef std::vector<float>          vectorf;
typedef std::vector<cv::Mat>        vectorMat;
typedef std::vector<cv::Point>      vectorPoint;
typedef std::vector<cv::Point3i>    vectorPoint3;
typedef std::vector<Candidate>      vectorCandidate;
typedef std::vector<MatlabIOContainer> vectorMatlabIOContainer;
typedef std::vector<cv::Ptr<cv::FilterEngine> > vectorFilterEngine;
// 2D
typedef std::vector<vectori>        vector2Di;
typedef std::vector<vectorf>        vector2Df;
typedef std::vector<vectorMat>      vector2DMat;
typedef std::vector<vectorMatlabIOContainer> vector2DMatlabIOContainer;
typedef std::vector<std::vector<cv::Ptr<cv::FilterEngine> > > vector2DFilterEngine;
// 3D
typedef std::vector<vector2Di>      vector3Di;
typedef std::vector<vector2DMat>    vector3DMat;
// 4D
typedef std::vector<vector3DMat>    vector4DMat;

I can't see what's going wrong, I checked my imgproc.hpp it doesn't contain any FilterEngine class, though the documentation says I should include imgproc.hpp [DOC] what is going wrong?(http://physics.nyu.edu/grierlab/manuals/opencv/classcv_1_1FilterEngine.html)

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
4

answered 2015-12-07 12:27:53 -0500

LorenaGdL gravatar image

I guess you're using 3.0.0? There's no class FilterEngine in 3.0.0 anymore.

edit flag offensive delete link more

Comments

Yes! I change to version 2.4.11 , problem solved, thank you .

YangTL gravatar imageYangTL ( 2015-12-08 06:09:25 -0500 )edit

You're welcome. Please, mark the question as solved (by they way, in the GitHub repo you can download version 2.4.12, which includes some new fixes for 2.4 tree)

LorenaGdL gravatar imageLorenaGdL ( 2015-12-08 06:11:37 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-12-07 10:00:01 -0500

Seen: 409 times

Last updated: Dec 07 '15