Ask Your Question
0

Missing opencv_rgbd library

asked 2015-12-07 09:18:40 -0500

Hi, I am totally new to this stuff but I am trying to compile some programs (Object Recogniton Kitchen) which need opencv. I had Opencv 2.4.8 installed on my system and everything was fine, but I had to remove it, so I used sudo find / -name "*opencv*" -exec rm -rf {} \; (I'm not sure if it was a good idea now) Then I installed Opencv 3.0.0 and I can't the compile ORK now. It gives me this output:

Base path: /home/tomas/ws
Source space: /home/tomas/ws/src
Build space: /home/tomas/ws/build
Devel space: /home/tomas/ws/devel
Install space: /home/tomas/ws/install
####
#### Running command: "cmake /home/tomas/ws/src -DCATKIN_DEVEL_PREFIX=/home/tomas/ws/devel -DCMAKE_INSTALL_PREFIX=/home/tomas/ws/install -G Unix Makefiles" in "/home/tomas/ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/tomas/ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/indigo
-- This workspace overlays: /opt/ros/indigo
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/tomas/ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.16
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 16 packages in topological order:
-- ~~  - ecto
-- ~~  - ecto_openni
-- ~~  - object_recognition_renderer
-- ~~  - opencv_candidate
-- ~~  - ecto_image_pipeline
-- ~~  - ecto_opencv
-- ~~  - ecto_ros
-- ~~  - ecto_pcl
-- ~~  - object_recognition_core
-- ~~  - object_recognition_capture
-- ~~  - object_recognition_linemod
-- ~~  - object_recognition_reconstruction
-- ~~  - object_recognition_tod
-- ~~  - object_recognition_transparent_objects
-- ~~  - object_recognition_tabletop
-- ~~  - object_recognition_ros_visualization
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'ecto'
-- ==> add_subdirectory(ecto)
-- Boost version: 1.54.0
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   date_time
--   python
--   regex
--   serialization
--   system
--   thread
-- Boost version 1.54.0
-- ecto commit:       e1847ef2a0aa3ae51ef0f034b41630959963c46c
-- ecto tag (long):   0.6.11-4-ge1847ef
-- ecto tag (short):  0.6.11
-- ecto last_mod:     Sun, 6 Dec 2015 18:56:43 +0100
-- Disabling testing since gtest was not found.
-- +++ processing catkin package: 'ecto_openni'
-- ==> add_subdirectory(ecto_openni)
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   python
--   thread
--   system
-- OpenNI version 1.5.7
-- Boost version: 1.54.0
-- Found the following Boost libraries:
--   serialization
--   filesystem
--   system
--   thread
-- OpenNI headers: /usr/include/ni
-- +++ processing catkin package: 'object_recognition_renderer'
-- ==> add_subdirectory(ork_renderer)
-- Boost version: 1.54.0
-- checking for module 'assimp'
--   found assimp, version 3.0.1264
-- Found assimp v3
-- +++ processing catkin package: 'opencv_candidate'
-- ==> add_subdirectory(opencv_candidate)
-- OpenCV version: 3.0.0
-- OpenCV headers: /usr/local/include/opencv;/usr/local/include
-- +++ processing catkin package: 'ecto_image_pipeline'
-- ==> add_subdirectory(ecto_image_pipeline)
-- Boost version: 1.54.0
CMake Error at /home/tomas/ws/devel/share/opencv_candidate/cmake/opencv_candidateConfig.cmake:141 (message):
  Project 'ecto_image_pipeline' tried to find library 'opencv_rgbd'.  The
  library is neither a target nor built/installed properly.  Did you compile
  project 'opencv_candidate'? Did you find_package() it before the
  subdirectory containing its code is included?
Call Stack (most recent call first):
  /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package)
  ecto_image_pipeline/CMakeLists.txt:5 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/tomas/ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/tomas/ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

It seems like it cannot find opencv libraries, maybe some paths must be add somewhere, but ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2015-12-07 20:50:13 -0500

Brandon212 gravatar image

RGBD is not part of the main opencv 3 release but is actually in the contrib modules, as you can see here: http://docs.opencv.org/master/#gsc.tab=0

If you download the contrib module release also, there's an option in cmake to include them.

edit flag offensive delete link more

Comments

Thank you for your reply, I tried to install contrib module as you suggested following this: https://github.com/itseez/opencv_contrib but it couldn't compile, giving error 2. I'll try to google something about it.

sykatch gravatar imagesykatch ( 2015-12-08 08:36:14 -0500 )edit

I'm not sure what you tried, but make sure that both the OCV3 and the contrib modules that you're using are the same version (i.e. don't download the repository itself, use the "release" tab at the top of the github page). If other contrib modules are the source of the error, you can always exclude them and just build rgdb also.

Brandon212 gravatar imageBrandon212 ( 2015-12-08 23:15:06 -0500 )edit

Yes I had to exclude one module, then it could built. But now the building process I posted in my question is giving dozens of compile errors. It's probably problem for another question.

sykatch gravatar imagesykatch ( 2015-12-09 02:05:16 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-12-07 09:17:57 -0500

Seen: 672 times

Last updated: Dec 07 '15