xphoto::inpaint Vector out of range

asked 2015-11-03 01:29:49 -0600

Hi, I am trying to use the xphoto::inpaint function implemented in opencv3.0 using VS 2013. however I am getting a vector error "Expression: vector iterator + offset out of range". I have tried the example code and still get the same error. Has anyone run into the same problem?

I think it might be coming from the annf.hpp header, but I am not 100% sure. I have attached my test script.

Thank you.

int main(int argc, char **argv) { if (argc != 3) { cerr << "Usage: " << argv[0] << " filename" << endl; return -1; } else {

    Mat data = readASCII(argv[1], 24, 24);
    Mat mask = readASCII(argv[2], 24, 24);

    Mat type_Cast;
    mask.convertTo(type_Cast, CV_8UC1);

    Mat paintedImg = Mat(24, 24, CV_64FC1);

    xphoto::inpaint(data, type_Cast, paintedImg, xphoto::INPAINT_SHIFTMAP);

    writeASCIIMat(paintedImg, "data_out.txt");

    return 0;




edit retag flag offensive close merge delete


I ran into the same problem as above. Did anyone find a solution for this?

spav gravatar imagespav ( 2017-04-12 16:52:59 -0600 )edit