Ask Your Question
2

OpenCV Android - Cannot Resolve Corresponding JNI Function

asked 2015-10-31 13:20:00 -0500

ConorB gravatar image

Hi, I'm trying to setup Android Studio with Opencv by following this tutorial outlined here: https://www.youtube.com/watch?v=OTw_G...

I can get the result obtained by the person giving the tutorial but upon trying to actually use some of Opencv's functions I run into some trouble.

I am able to load the Opencv library but upon trying use some of the native functions such as "Imgcodecs.imread" I get the error: ".lang.UnsatisfiedLinkError: No implementation found for long org.opencv.imgcodecs.Imgcodecs.imread_1(java.lang.String)"

I believe I have tracked down the issue to the following:

image description

It seems that Android Studio is unable to detect the native C++ code which I'm guessing should be picked up from jiniLibs folder I now have in app/src/main?

I've tried updating Android Studio to the latest stable build and I have fixed my file paths for my android SDK and NDK as having white-space can apparently affect the running of native code. The issue still persists.

I have been trying to fix this for the last 4 hours, any help would be greatly appreciated!

edit retag flag offensive close merge delete

Comments

Have you found a solution?

bighealthkick gravatar imagebighealthkick ( 2016-07-01 05:35:08 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-09-22 19:50:44 -0500

dtdzung gravatar image

this videos exactly match what you need about configuration opencv. ndk and android studio https://www.youtube.com/watch?v=Oq3oi...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-31 13:17:15 -0500

Seen: 4,736 times

Last updated: Oct 31 '15