Ask Your Question
1

Need help - building opencv3.0 with Cuda 7.5 on Windows VS2010, cmake error

asked 2015-10-12 04:40:13 -0500

Yafewan gravatar image

If I configure CMake with WITH_CUDA unchecked , everything works fine. However, when I checked WITH_CUDA. I have one issue in CMake, and if I continue to build, I get many errors.

It seems that there there some libs can't find, but I don't know how to deal with it.

My computer is win7 x86_64bit.

The output just like this:

found IPP (ICV version): 8.2.1 [8.2.1] at: D:/OpenCV/opencv/sources/3rdparty/ippicv/unpack/ippicv_win CUDA detected: 7.5 CUDA NVCC target flags: -gencode;arch=compute_20,code=sm_20;-gencode;arch=compute_20,code=sm_21;-gencode;arch=compute_30,code=sm_30;-gencode;arch=compute_35,code=sm_35;-gencode;arch=compute_30,code=compute_30 Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) To enable PlantUML support, set PLANTUML_JAR environment variable or pass -DPLANTUML_JAR=<filepath> option to cmake Could NOT find PythonLibs (missing: PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS) (Required is exact version "2.7.9") Traceback (most recent call last): File "<string>", line 1, in <module> ImportError: No module named numpy.distutils

Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "3.4") Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "3.2") Could NOT find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY JAVA_INCLUDE_PATH JAVA_INCLUDE_PATH2 JAVA_AWT_INCLUDE_PATH) VTK is not found. Please set -DVTK_DIR in CMake to VTK build directory, or to VTK install subdirectory with VTKConfig.cmake file videoio: Removing WinRT API headers by default

General configuration for OpenCV 3.0.0 ===================================== Version control: unknown

Platform: Host: Windows 6.1 AMD64 CMake: 3.3.2 CMake generator: Visual Studio 10 2010 CMake build tool: C:/Windows/Microsoft.NET/Framework/v4.0.30319/MSBuild.exe MSVC: 1600

C/C++: Built as dynamic libs?: YES C++ Compiler: C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC/bin/cl.exe (ver 16.0.30319.1) C++ flags (Release): /DWIN32 /D_WINDOWS /W4 /GR /EHa /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _SCL_SECURE_NO_WARNINGS /Gy /bigobj /arch:SSE2 /Oi /fp:fast /wd4251 /wd4324 /MP4 /MD /O2 /Ob2 /D NDEBUG /Zi C++ flags (Debug): /DWIN32 /D_WINDOWS /W4 /GR /EHa /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _SCL_SECURE_NO_WARNINGS /Gy /bigobj /arch:SSE2 /Oi /fp:fast /wd4251 /wd4324 /MP4 /D_DEBUG /MDd /Zi /Ob0 /Od /RTC1 C Compiler: C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC/bin/cl.exe C flags (Release): /DWIN32 /D_WINDOWS /W3 /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _SCL_SECURE_NO_WARNINGS /Gy /bigobj /arch:SSE2 /Oi /fp:fast /MP4 /MD /O2 /Ob2 /D NDEBUG /Zi C flags (Debug): /DWIN32 /D_WINDOWS /W3 /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _SCL_SECURE_NO_WARNINGS /Gy /bigobj /arch:SSE2 /Oi /fp:fast /MP4 /D_DEBUG /MDd /Zi /Ob0 /Od /RTC1 Linker flags (Release): /machine:X86 /INCREMENTAL:NO /debug Linker flags (Debug): /machine:X86 /debug /INCREMENTAL Precompiled headers: YES Extra dependencies: cudart CUDA_nppc_LIBRARY-NOTFOUND CUDA_nppi_LIBRARY-NOTFOUND CUDA_npps_LIBRARY-NOTFOUND CUDA_cufft_LIBRARY-NOTFOUND 3rdparty dependencies: ippicv

OpenCV modules: To be built: hal cudev core cudaarithm flann imgproc ml video cudabgsegm cudafilters cudaimgproc cudawarping imgcodecs photo shape videoio cudacodec highgui objdetect ts features2d calib3d cudafeatures2d cudalegacy cudaobjdetect cudaoptflow cudastereo stitching superres videostab Disabled: world Disabled by dependency: - Unavailable: java python2 python3 viz

Windows RT ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-12 13:00:04 -0500

panmari gravatar image

I recently had the same problem. Turns out, I had the 64 bit version of CUDA installed, so I also needed to compile opencv in 64 bit mode. So in your case, instead of using

CMake generator: Visual Studio 10 2010

You should use the x64 generator. Then, all necessary CUDA libraries will be found.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-12 04:40:13 -0500

Seen: 1,168 times

Last updated: Oct 12 '15