Ask Your Question

Cannot install contributors modules for opencv 3 beta

asked 2015-07-15 05:44:21 -0600

Caba gravatar image

Hi all,

I'm facing several hours on installing opencv_contrib modules for opencv 3 beta. I can build and install opencv 3 beta correctly without problems and is working too. Then, looking at this answer I donwloaded the version of opencv_contrib for the opencv beta version. The to compile I run the command how specified in the repository of opencv_contrib, that is:

$ cmake -DOPENCV_EXTRA_MODULES_PATH=../../opencv_contrib/modules ..

Where the opencv_contrib folder is placed in the same folder where the opencv-3.0.0-beta is located. Doing that command I got the error:

  Unknown CMake command "ocv_include_modules_recurse".

The person on that question resolved this problem simply by donwloading the opencv_contrib for the beta version (before he was using the master). But for me this is not working (I tried also with both).

To resolve that error I found this question that suggests to use the command:

   $ cmake -DOPENCV_EXTRA_MODULES_PATH=opencv_contrib/modules .

This is working well, I can then build with make but it seems that is not building anything because it tries to build all the opencv "standards" modules that I have previously built. But, in the folder build/modules/ the folders of the modules of the opencv_contrib have appeared (then the cmake -DOP.......), but they are empty, the have no headers, also then the building.

edit retag flag offensive close merge delete


Thanks, I will try in a while

Caba gravatar imageCaba ( 2015-07-15 05:56:40 -0600 )edit

Thanks, It worked perfectly. Both compilation and building with no errors, and the usr/locacl/include/opencv2 folder contains knwo the headers files of the modules.

I don't know very well how it works, but if you write it as an answer I will accept it!

Caba gravatar imageCaba ( 2015-07-15 07:32:10 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-07-15 05:54:46 -0600

LBerger gravatar image

updated 2015-07-15 07:43:52 -0600

  1. delete CMakeCache.txt
  2. give full path with -DOPENCV_EXTRA_MODULES_PATH options
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-07-15 05:44:21 -0600

Seen: 506 times

Last updated: Jul 15 '15