Jar is not created

asked 2015-07-08 16:50:06 -0500

miro gravatar image

Hello, i spent 3 days reading manuals and issues how to build opencv, but i still not get jar files. Please help me. Here is cmake output.

Detected version of GNU GCC: 51 (501) CUDA compilation is disabled (due to only Visual Studio compiler supported on your platform). Could NOT find Doxygen (missing: DOXYGEN_EXECUTABLE) To enable PlantUML support, set PLANTUML_JAR environment variable or pass -DPLANTUML_JAR=<filepath> option to cmake Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "2.7") Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) (Required is at least version "2.6") Could NOT find PythonLibs (missing: PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS) (Required is exact version "3.4.3") Traceback (most recent call last): File "<string>", line 1, in <module> ImportError: No module named 'numpy'

Found apache ant 1.9.6: c:/apache_ant/bin/ant.bat ERROR: The system was unable to find the specified registry key or value.

ERROR: The system was unable to find the specified registry key or value.

Could NOT find Matlab (missing: MATLAB_MEX_SCRIPT MATLAB_INCLUDE_DIRS MATLAB_ROOT_DIR MATLAB_LIBRARIES MATLAB_LIBRARY_DIRS MATLAB_MEXEXT MATLAB_ARCH MATLAB_BIN) VTK is not found. Please set -DVTK_DIR in CMake to VTK build directory, or to VTK install subdirectory with VTKConfig.cmake file CMake Warning (dev) at cmake/OpenCVPCHSupport.cmake:80 (GET_DIRECTORY_PROPERTY): Policy CMP0059 is not set: Do no treat DEFINITIONS as a built-in directory property. Run "cmake --help-policy CMP0059" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): cmake/OpenCVPCHSupport.cmake:256 (_PCH_GET_COMPILE_FLAGS) cmake/OpenCVPCHSupport.cmake:369 (add_precompiled_header) cmake/OpenCVModule.cmake:835 (ocv_add_precompiled_header_to_target) cmake/OpenCVModule.cmake:806 (_ocv_add_precompiled_headers) cmake/OpenCVModule.cmake:688 (_ocv_create_module) cmake/OpenCVModule.cmake:857 (ocv_create_module) modules/hal/CMakeLists.txt:12 (ocv_define_module) This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at CMakeLists.txt:618 (add_subdirectory): Policy CMP0059 is not set: Do no treat DEFINITIONS as a built-in directory property. Run "cmake --help-policy CMP0059" for policy details. Use the cmake_policy command to set the policy and suppress this warning. This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at cmake/OpenCVPCHSupport.cmake:80 (GET_DIRECTORY_PROPERTY): Policy CMP0059 is not set: Do no treat DEFINITIONS as a built-in directory property. Run "cmake --help-policy CMP0059" for policy details. Use the cmake_policy command to set the policy and suppress this warning. Call Stack (most recent call first): cmake/OpenCVPCHSupport.cmake:256 (_PCH_GET_COMPILE_FLAGS) cmake/OpenCVPCHSupport.cmake:369 (add_precompiled_header) cmake/OpenCVModule.cmake:835 (ocv_add_precompiled_header_to_target) cmake/OpenCVModule.cmake:806 (_ocv_add_precompiled_headers) cmake/OpenCVModule.cmake:688 (_ocv_create_module) modules/core/CMakeLists.txt:26 (ocv_create_module) This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at CMakeLists.txt:618 (add_subdirectory): Policy CMP0059 is not set: Do no treat DEFINITIONS as a built-in directory property. Run "cmake --help-policy CMP0059" for policy details. Use the cmake_policy command to set the policy and suppress this warning. This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at cmake/OpenCVPCHSupport.cmake:80 (GET_DIRECTORY_PROPERTY): Policy CMP0059 is not set ... (more)

edit retag flag offensive close merge delete

Comments

"ERROR: The system was unable to find the specified registry key or value."

  • sounds, like your java sdk is broken
berak gravatar imageberak ( 2015-07-09 04:06:08 -0500 )edit