Ask Your Question
0

not able to include non free OpenCV 3.0

asked 2015-07-01 05:55:17 -0500

maystroh10 gravatar image

I'm trying to use SURF/SIFT in the alpha version of the OpenCV 3.0. I already checked these links 1,2,3,4 without being able to solve the error occured when I include "opencv2/xfeatures2d/nonfree.hpp".

I debrief below what I've tried:

  1. I knew that SURF/SIFT are now in a separate module and we should load it upon builiding OpenCV to make it work so I got the module repository from this link and I built OpenCV using the following command :

cmake -DOPENCV_EXTRA_MODULES_PATH=/home/opencvContrib/modules ..

  1. Here is a text extracted from the results displayed after running this command:

OpenCV modules:

  1. To be built: core flann imgproc imgcodecs videoio highgui features2d calib3d ml objdetect photo video shape stitching superres ts videostab
  2. Disabled: world
  3. Disabled by dependency: -
  4. Unavailable: androidcamera cuda cudaarithm cudabgsegm cudacodec cudafeatures2d cudafilters cudaimgproc cudalegacy cudaoptflow cudastereo cudawarping cudev java python2 python3 viz

It seems to me weird to have these modules because they are just the modules in the openCV repository and none of them are from the module repository so I would assume it as a reason for my problem.

Any idea on what's going on?

edit retag flag offensive close merge delete

Comments

can you add the complete cmake output to your question ? (even if it's long)

berak gravatar imageberak ( 2015-07-01 06:18:23 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-06 03:44:11 -0500

maystroh10 gravatar image

I was able to figure it out. The problem was in the path of the contrib module so putting the correct one has fixed it.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-07-01 05:55:17 -0500

Seen: 413 times

Last updated: Jul 06 '15