Ask Your Question
2

VideoCapture android 3.0.0

asked 2015-06-08 06:06:45 -0500

surcz gravatar image

updated 2015-06-12 02:31:52 -0500

Hi,

I've found CV_CAP_ANDROID is marked as 'unused' but anyway, I've tried new VideoCapture(CV_CAP_ANDROID), tried new VidoCapture() tried capture->open(CV_CAP_ANY) and I always get ->isOpened() = false;

I have CAMERA permission in Android manifest.

What may be wrong here? Was anybody ableto start capture with native opencv 3.0.0 on android. thanks.

ps. I'm working qith QT project and everything buids without ny problem, the problem at runtime only, I see nothing wrong in output, VideoCapture just doesn't open

edit retag flag offensive close merge delete

Comments

mshabunin gravatar imagemshabunin ( 2015-07-21 03:38:00 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-20 17:12:44 -0500

surcz gravatar image

I see opencv manager beta description contains "as well as new OpenCV 3.0-based Java applications should work well)", looks like it's known problem(feature?), but I don't know neither issue number nor roadmap if native is going to be supported later. So, no luck with native+android+opencv 3.0.0?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2015-06-08 05:28:48 -0500

Seen: 1,497 times

Last updated: Jul 20 '15