Ask Your Question
0

QTKit didn't find any attached Video Input Devices!

asked 2013-01-21 20:58:18 -0500

karlphillip gravatar image

updated 2013-01-21 20:59:44 -0500

The following error occurs whenever I try to run a simple application to grab frames from the camera of a Macbook Pro 13" (built-in iSight):

QTKit didn't find any attached Video Input Devices!
Warning, camera failed to properly initialize!
Cleaned up camera.

I've tried passing -1, 0, 1 and other values as parameters to cvCreateCameraCapture() and none worked. It's important to say that I used OpenCV 2.3.1 on this machine for quite a while and it worked fine passing -1 as parameter.

This problem seems to happen with OpenCV v2.4.2 and v2.4.3 on Mac OS X 10.7.5.

Any ideas?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-02-05 18:18:53 -0500

karlphillip gravatar image

I've solved this issue with a temporary fix.

This problem is probably specific to my system.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-01-21 20:58:18 -0500

Seen: 1,751 times

Last updated: Feb 05 '13