Ask Your Question
1

ximgproc - detectEdges() cloudyImages as result

asked 2015-05-26 10:31:22 -0500

raffael gravatar image

updated 2015-05-28 09:49:14 -0500

Hello,

I am using the Structured Edge Detection Toolbox V3.0 in Matlab where I trained some models. In Matlab the result images are good, and edges are detected correctly. Now I wanted to use OpenCV with the ximgproc solution. Inside this packes there is a matlab function where you can transform your model into the yml format. I followed all the steps, but the result images are every time cloudy and without edges. I tested more models, also the BSDS500 dataset with the same result. Only the model which is in the modul is working fine..

Any suggestions? Someone with the same problem?

Example: Input Image: image description

Result Image with Model from Ximgproc Package: image description

Result Image with own trained Models: image description

Thank you!

edit retag flag offensive close merge delete

Comments

Can you post some images?

thdrksdfthmn gravatar imagethdrksdfthmn ( 2015-05-26 10:45:13 -0500 )edit

do you have a compression there?and by the way, put the images in the question, not in comments, it looks ugly

thdrksdfthmn gravatar imagethdrksdfthmn ( 2015-05-27 06:30:48 -0500 )edit

you mean in the input images? or the images the model was learned? well some images are coming from a scanner, but with the sample images from the package it doesnt work for the trained models too..

raffael gravatar imageraffael ( 2015-05-27 06:33:19 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-07-08 06:54:49 -0500

raffael gravatar image

Hello,

well in the end i couldn't solve the problem using the opencv ximgproc functions. Finally I wrote my own code using parts of the matlab mex code from the microsoft toolbox and it's working fine with my own trained and other models. Another change is not to use de yaml format to read the model. Much faster is it to save it binary and read it then.

Thanks

edit flag offensive delete link more

Comments

So you have done this in Matlab and ... wait, mex is making the C++ code to be readable by Matlab, no? Please post the things that you used for making it work.

thdrksdfthmn gravatar imagethdrksdfthmn ( 2015-07-08 07:05:50 -0500 )edit
0

answered 2015-08-27 07:32:06 -0500

Hi,

I've faced the same problem. To fix this you need to train your models with the option 'sharpen' set to 0. Currently, the code does not support models trained with 'sharpen' set to anything but 0. I'll work on adding the missing piece of code from Piotr Dollar's toolbox.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-05-26 10:31:22 -0500

Seen: 328 times

Last updated: Jul 08 '15