Ask Your Question

64bit Android

asked 2015-04-17 09:22:09 -0500

St3venAU gravatar image

Hi, I am trying to use OpenCV in an Android application that will be run on the Galaxy S6 which runs a 64 bit version of Android. I am getting the following error:

dlopen failed: "/data/app/org.opencv.engine-1/lib/arm/" is 32-bit instead of 64-bit

Does anyone know if there is a solution for this?

edit retag flag offensive close merge delete


OpenCV Manager support for Android 64 bit is not ready yet. As a temporary measure, you can try to put corresponding 32-bit into your apk.

mshabunin gravatar imagemshabunin ( 2015-04-17 11:06:35 -0500 )edit

Thanks. That worked.

St3venAU gravatar imageSt3venAU ( 2015-04-17 16:17:53 -0500 )edit

please how to solve this? i didn't understand how to compile libopencv to my android. please tell me how to compile this lib to my eclipse/android studio.. thanks

kangkamal gravatar imagekangkamal ( 2016-08-04 03:24:10 -0500 )edit

Download SDK here: And follow the instructions from documentation and tutorials:

mshabunin gravatar imagemshabunin ( 2016-08-05 03:21:24 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-08-05 05:05:10 -0500

Yeah... Just copied x86_x64 to jniLibs on Android studio... Worked for me, big thanks :D

edit flag offensive delete link more

Question Tools



Asked: 2015-04-17 09:22:09 -0500

Seen: 2,573 times

Last updated: Apr 17 '15