Ask Your Question
1

OpenCV 3.0 BETA - can't open video files

asked 2015-02-28 11:32:31 -0500

matga gravatar image

updated 2015-03-01 06:12:12 -0500

When i want to open video file with VideoCapture, the isOpened() returns everytime false. But VideoCapture works with the camera. I use build from the opencv.org. It worked few days ago, but i forgot what i did to work. :P

So my question is, what should i do, if after VideoCapture video_in("video.mp4"); video_in.isOpened() returns false? Is it wrong settings, or did i forget add some libs?

Thank you.

[EDIT] Problem solved, i coied opencv_ffmpeg300.dll to debug folder, and it works now.

edit retag flag offensive close merge delete

Comments

Could you specify the full path of the debug folder?

Cotangent gravatar imageCotangent ( 2015-05-23 12:10:54 -0500 )edit

Could you specify the full path of the debug folder?

Deliss gravatar imageDeliss ( 2015-11-02 10:55:00 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-23 18:47:19 -0500

I experienced the same problem. I resolved it adding the location of opencv_ffmpeg300_64.dll (for instance: <path_to_opencv>\opencv\build\x64\vc12\bin) to my PATH variable.

edit flag offensive delete link more
0

answered 2015-02-28 15:37:12 -0500

adliner gravatar image

updated 2015-02-28 15:39:57 -0500

Perhaps some file access permission problem here? Have you tried running with privileged rights? Or maybe you should specify the full path to video file, CWD could be set to some other location than you expect.

edit flag offensive delete link more
-1

answered 2015-10-24 17:45:47 -0500

Sonny gravatar image

updated 2015-10-24 17:46:19 -0500

Isn't FFMpeg GPL licensed? I think you can't use FFMpeg in a commercial application

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-02-28 11:32:31 -0500

Seen: 1,651 times

Last updated: Oct 24 '15