Unsatisfied Link Error while directly loading Native library for opencv in eclipse Mac 10.9.5

asked 2015-02-10 01:24:25 -0500

mparatp gravatar image

So, I am trying to use OpenCV with Eclipse in Mac 10.9.5 in a Maven project for software automation testing.

While using OpenCV i got NoClassDefFoundError so I gave - System.loadLibrary(Core.NATIVE_LIBRARY_NAME);

After which it started giving - Exception in thread "main" java.lang.UnsatisfiedLinkError: no opencv_java249 in java.library.path

So, after a lot of googling i found out that - System.loadLibrary("Complete Path to opencv.dll") works for Windows. But still it doesnt work for Mac as there are no precompiled .dlls. I tried searching for libOpenCV.jnilib/.dylib but couldnt find them as OpenCV is not installed in the Mac. Even if we are able to install it using cmake/macports i couldnt find any build folder with the required .jnilib/.dylib .

Later, I found out this - http://ubaa.net/shared/processing/ope...

and this https://decohan.wordpress.com/2011/08... but this also doesnt work as when putting -d32 in the arguments tab, it says 32bit not supported by JVM. So, i tried searching 32 bit JDK for Mac, but there is no such JDK.

Apart from it, directly giving the .dll path seems to be a workaround, if you can suggest any better way, then it s better.

So, all in all if anyone can help me regarding this opencv error then it would be a great help. Am trying to do this for a week now. But no luck.

This is the link for my Stack OverFlow post : http://stackoverflow.com/questions/28...

edit retag flag offensive close merge delete

Comments

Were you ables to find a solution? I am stuck on this issue too! Thanks!

jtcjara gravatar imagejtcjara ( 2015-03-27 10:39:20 -0500 )edit