Very hard time with paths on VS2013 Express & OpenCV 2.4.10

asked 2014-12-30 19:24:31 -0500

rholt gravatar image

updated 2014-12-31 18:24:25 -0500

i first started trying to use OpenCV 3.0 - it will be good in that there are only 2 Linker input files for both release & debug - but i had a very hard time spending many hours to get it successfully installed on my Win 7 (64bit) thinkpad. I've read that that there are still some bugs to be worked out so i've uninstalled 3.0 and have installed OpenCV 2.4.10. I'm a little surprised that the Install instructions for Visual Studio has not been updated for the more recent VS versions, especially when the Linker>>Input>>Additional Dependencies files have changed through at least two iterations (probably three). Getting to my problem... I went and installed OpenCV off of the C:\ directory in order to keep things simple. the Windows installation suggests this addition for the Environmental Path: setx -m OPENCV_DIR C:\OpenCV\Build\x64\vc11 (suggested for Visual Studio 2012 - 64 bit Windows) I get doing this, although I use vc12 as it was suggested to use this for VS2012. and i also added a "PATH"
;%OPENCV_DIR%\x64\bin getting into VS2013(express)... I've gone into properties>>C++>>General>>Additional Include Directories: $(OPENCV_DIR)....\include I'm assuming that this brings the path backwards in order to correctly point to the "Include" directory. so this brings us to the two problems that i'm getting when Run (in VS) either "debug" or "release"... 1) in order to get my #include opencv2/core/core.hp to work, i have to change that "Additional Include Directories" to: $(OPENCV_DIR)\include and take away the "...." directives. (apologies if this is not the correct terminology). if i DO this and "Start without Debugging" {ctrl F5} then i ge the following error: LNK1181 cannot open input file 'opencv_calib3d2410.lib' this happens when running release, the same file with 'd' @ the end when i run debug. This file is the 1st file name under "Linker>>Input>> Additional Dependencies" I've checked the spelling. this file, along with all the other "Additional Dependancies" files are located in my: C:\OpenCV\build\x64\vc12\bin directory. meh. please help. Russ from Coral Springs, Florida, USA

20141231 7:26pm - It looks as though whatever file i put in the top of my list of "Additional Dependencies" is the file that the program "cannot open"... I'm not sure what this means but maybe that helps? (i'm hoping the screenshot i uploaded will be visible to you all.)

C:\fakepath\OpenCV_addl_dependancies.jpg

edit retag flag offensive close merge delete

Comments

i have the same issue with openCV 3.1.0. Could you please update here when you solve?

kusrabaratay gravatar imagekusrabaratay ( 2016-01-18 06:54:33 -0500 )edit