calcOpticalFlowPyrLK() - Python does not work on Mac?

asked 2014-11-13 22:40:54 -0500

I am having trouble trying to get the lk_track.py sample to to work on my Mac (not sure if Windows or Linux also get this error). I am using openCV 3.0.0 HEAD version that I got through brew. I can not use the 2.4.9 release version due to some kind of error (Same error output described here) and maybe this is related.

When I tried running the lk_track.py sample I get the following error when cv2.calcOpticalFlowPyrLK() is called:

OpenCV Error: Image step is wrong (Step must be a multiple of esz1) in setSize, file /tmp/opencv-P6BF4O/modules/core/src/matrix.cpp, line 297 libc++abi.dylib: terminating with uncaught exception of type cv::Exception: /tmp/opencv-P6BF4O/modules/core/src/matrix.cpp:297: error: (-13) Step must be a multiple of esz1 in function setSize

I tried rescaling the video input to several other resolutions but that don't seem to work. The code in the tutorial that is using cv2.calcOpticalFlowPyrLK() also gives this error. Does anyone know what is wrong?

edit retag flag offensive close merge delete