OpenCV3.0 missing headers and libraries.

asked 2014-10-21 18:45:15 -0500

knox gravatar image

Hi Guys, Iam trying to build opencv 3.0 from source. I downloaded the source code and using cmake I generated the OpenCV.sln file. I built the visual studio sln file in both debug and release modes. And I was able to run the samples. So far everything went well.

Now, I try to create a sample application in Visual Studio. I include the header files from "build/include" but unfortunately, there are no header files in this folder. I only see some cmake files, but no header files. Also build/x64 is supposed to have vc10,11,and 12 folders with respective lib,bin and statlib folders in it. But they are all missing. I only have some cmake files in the build/x64 folder. No libraries.

I also tried using the pre-built libraries by downloading and extracting from the sourceforge.net. build/include folder has the header files. But build/x64/vc12/lib doesn't have all the libraries. Its having only world300 and ts300 libraries, all the other libraries are missing.

I never had these issues with opencv 2.49. Any help in what I missing would be highly appreciated.

edit retag flag offensive close merge delete

Comments

2

after building the opencv libs, run the INSTALL project. this will copy all headers/libs/dll to build/install

berak gravatar imageberak ( 2014-10-22 01:58:34 -0500 )edit

Do I need to select the INSTALL_CREATE_DISTRIB option in the cmake config step ?

knox gravatar imageknox ( 2014-10-22 12:46:14 -0500 )edit

no real idea, it's not set here.

berak gravatar imageberak ( 2014-10-22 12:55:28 -0500 )edit

I get this message when I build the OpenCV.sln file :

7>------ Skipped Build: Project: PACKAGE, Configuration: Release x64 ------ 7>Project not selected to build for this solution configuration

8>------ Skipped Build: Project: INSTALL, Configuration: Release x64 ------ 8>Project not selected to build for this solution configuration ========== Build: 2 succeeded, 0 failed, 51 up-to-date, 6 skipped ==========

knox gravatar imageknox ( 2014-10-22 13:47:40 -0500 )edit

that is probably about BUILD_PACKAGE, which should be set to ON.

berak gravatar imageberak ( 2014-10-22 13:53:13 -0500 )edit

BUILD_PACKAGE is ON by default and I never changed it. I tried to ON and OFF the INSTALL_CREATE_DISTRIB but both the times I get that error where its not building INSTALL Project

knox gravatar imageknox ( 2014-10-22 14:04:25 -0500 )edit

sorry, dear, i'm out of ideas.

berak gravatar imageberak ( 2014-10-22 14:19:03 -0500 )edit

Okay I figured out what is going wrong here... Build INSTALL project manually from the OpenCV.sln by right clicking - > build. This will create the libraries in build/install/x86/vc12 folder. This is where lib,bin and staticlib folders are now residing. Also the include files are in build/install/include.

knox gravatar imageknox ( 2014-10-22 16:22:14 -0500 )edit

I have the same problem. Any solution?

Thanks

DiegoDVG gravatar imageDiegoDVG ( 2016-01-05 13:53:37 -0500 )edit

And how can I build "INSTALL" for release? I selected in Visual Studio "Release x64", but only the build/install/debug folder appears and not the release folder.

bingoblau gravatar imagebingoblau ( 2017-02-10 09:36:45 -0500 )edit