Build error under Windows

asked 2014-10-10 18:00:40 -0500

kovand11 gravatar image

updated 2014-10-20 12:36:37 -0500

With the following cmake settings:

  • mingw
  • All defaults
  • OPENCV_EXTRA_MODULES_PATH given

Compilation fails:

image description

Any idea, how to fix?

EDIT:

CMake output: http://pastebin.com/3HVJAqwX

MinGW output: http://pastebin.com/X3fZFPdk (4.8.1-4 version)

opencv: 55f490485bd58dc972de9e0333cdff005fce1251 (master latest)

opencv_contrib: 49102c7e7a44dd7c0cc992c27e52a9547aad745e (master latest)

edit retag flag offensive close merge delete

Comments

2

could you try to provide error text instead of an unreadable screenshot ?

also, opencv version, mingw version, etc. required..

berak gravatar imageberak ( 2014-10-11 01:57:58 -0500 )edit
1

ok, so the line_descriptor module did not build for you.

  1. make an issue here with your findings.
  2. disable that module: cmake -D BUILD_opencv_line_descriptor=OFF
berak gravatar imageberak ( 2014-10-20 13:09:16 -0500 )edit

A small search, several solutions:

http://stackoverflow.com/questions/2520683/how-to-cope-with-intrin-h-no-such-file-or-directory

Reason for this, the intrin.h is simply not known by the mingw compiler, where the buildbot doesn't test for that. Go try and use the suggested fixes!

StevenPuttemans gravatar imageStevenPuttemans ( 2014-10-21 06:28:36 -0500 )edit

And if you do succeed in fixing it, then please supply your fix as a PR.

StevenPuttemans gravatar imageStevenPuttemans ( 2014-10-21 06:29:48 -0500 )edit